Closed Bug 306674 Opened 15 years ago Closed 5 years ago

SVG clipPath in symbol not interpreted

Categories

(Core :: SVG, defect)

x86
Windows 2000
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 353575

People

(Reporter: domob, Unassigned)

References

Details

(Keywords: testcase)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050828 SeaMonkey/1.1a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050828 SeaMonkey/1.1a

A svg:clipPath element, which is defined inside a symbol-element, can't be
referenced (isn't applied); moving it out of the symbol (into defs), it works.

As clipPath is allowed in the content model of symbol (at least in the SVG 1.1
Recommendation), I suppose it should be allowed there.

Reproducible: Always

Steps to Reproduce:
Open the sample file, which is the same as that of Bug 193825, except that it
uses symbols & references.
Actual Results:  
No clipping is done.

Expected Results:  
The clipPath should be applied.
Attached image Triggering the bug.
This is the same test case as for Bug 193825, except that the rectangle &
clippath are defined inside a symbol which is referenced later. Moving the
clipPath element one level up (making it a child of defs) it works.
Keywords: testcase
I CONFIRM this bug.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050912
Firefox/1.6a1
This is still present on trunk, but I'm not sure how valid/useful it is to have a <clipPath> _inside_ a <symbol>, or whether we really care to use up time allowing that.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Is this too time expensive?

I work as gr. designer and I can imagine using such construction...
What stops you putting the <clipPath> outside of the <symbol> instead of inside?
Nothing :) 

But, I think if this is not prohibited by the SVG standard

http://www.w3.org/TR/SVG11/masking.html#ClipPathElement

we should allow designers create such construction...

otherwise we will cause compatility problems... by my opinion.
Assignee: general → nobody
QA Contact: ian → general
Seems to work now both in trunk and in Firefox 3.6.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Actually it doesn't work. Previous releases didn't clip at all. 3.6 and above now clip everything regardless of what the clip path should clip.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The attached .zip contains a .svg that contains 2 implementations of a clip-path use, both should render the same way. A PNG of how it should look after the 2 intersections are done is also included.
Comment 9 is unrelated it is bug 534612 which is fixed on the trunk.
Attachment #440115 - Attachment is obsolete: true
Duplicate of this bug: 1148358
Status: REOPENED → RESOLVED
Closed: 11 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353575
You need to log in before you can comment on or make changes to this bug.