Javascript error with certain characters in array.

RESOLVED FIXED in Bugzilla 2.16

Status

()

Bugzilla
Query/Bug List
P2
normal
RESOLVED FIXED
19 years ago
6 years ago

People

(Reporter: Michael Maher, Assigned: Christian Reis)

Tracking

2.10
Bugzilla 2.16
x86
Linux

Details

(URL)

(Reporter)

Description

19 years ago
If there are components or programs in the query list that have 
a ' in their name, the query list will not work.

here is the Javascript error for a component name of  " rpm's "

JavaScript Error: http://bugs.lastfoot.net/query.cgi,
line 53:

missing ] in index expression. 

cpts['rpm's'] = new Array();
..........^

JavaScript Error: http://bugs.lastfoot.net/query.cgi,
line 6:

selectProduct is not defined.

Comment 1

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv
QA Contact: matty
Whiteboard: 2.14

Updated

18 years ago
Whiteboard: 2.14 → 2.16
moving to real milestones...
Target Milestone: --- → Bugzilla 2.16

Comment 4

17 years ago
*** Bug 63919 has been marked as a duplicate of this bug. ***
*** Bug 81195 has been marked as a duplicate of this bug. ***
Severity: minor → normal
Priority: P3 → P2
Whiteboard: 2.16

Comment 6

17 years ago
moving, this needs to be escaped.
Assignee: tara → endico
Component: Bugzilla → Query/Bug List
Product: Webtools → Bugzilla
Version: other → 2.10
(Assignee)

Comment 7

17 years ago
I'm fixing this together with 96534. It seems nobody had the guts to fix that JS
code :)
Assignee: endico → kiko
Depends on: 96534
(Assignee)

Comment 8

17 years ago
Reporter, can you please upgrade to 2.14, or apply the patch included in
96534, and reopen if you see the problem isn't solved? Testing on
http://landfill.tequilarista.org/bz96534/query4.cgi (Product
MyOwnBadSelf) has shown that single quotes are now properly escaped.

Marking FIXED due to checkin for 96534.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

17 years ago
Sorry for the extra spam; this didn't make it into 2.14 but is included
in the latest CVS version (and remember patch v13 too).
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.