Closed Bug 307173 Opened 14 years ago Closed 13 years ago

Cells within tables within an absolute div within an absolute div are rendered inline.

Categories

(Core :: Layout: Positioned, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 201897

People

(Reporter: pcholt, Unassigned)

References

()

Details

(Whiteboard: [reflow-refactor])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

A table within a div with position:absolute within another div with
position:absolute renders all its td elements inline. In other words, the cells
within the table are no longer aligned in columns.

Reproducible: Always

Steps to Reproduce:
1. Create an example file containing this code snippet:
  <div style=position:absolute><div style=position:absolute>
  <table>
  <tr><td>cell1</td><td>cell2</td></tr>
  <tr><td>cell2 long</td><td>cell3</td></tr>
  <tr><td>cell4</td><td>cell6 long</td></tr>
  </table>
  </div></div>
2. Run this

Actual Results:  
+----------------------------------+
| .-------. .-------.              |
| | cell1 | | cell2 |              |
| `-------' `-------'              |
| .---------------. .-------.      |
| | cell3 is long | | cell6 |      |
| `---------------' `-------'      |
| .-------. .------------.         |
| | cell5 | | cell6 long |         |
| `-------' `------------'         |
`----------------------------------'

Expected Results:  
+----------------------------------+
| .---------------. .------------. |
| | cell1         | | cell2      | |
| `---------------' `------------' |
| .---------------. .------------. |
| | cell3 is long | | cell6      | |
| `---------------' `------------' |
| .---------------. .------------. |
| | cell5         | | cell6 long | |
| `---------------' `------------' |
`----------------------------------'

This also happens in Mozilla.
Duplicate of/related to Core bug 228781 -> Core bug 201897?
Component: General → Layout: R & A Pos
Product: Firefox → Core
QA Contact: general → layout.r-and-a-pos
Version: unspecified → Trunk
Whiteboard: [reflow-refactor]
Provided URL is no longer reachable, fetchable. Resolving as DUPLICATE of bug 201897
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 201897
You need to log in before you can comment on or make changes to this bug.