Closed Bug 307315 Opened 17 years ago Closed 17 years ago

JS labeled as version 1.6 does't work

Categories

(Core :: JavaScript Engine, defect, P1)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED
mozilla1.8beta4

People

(Reporter: nanto, Assigned: brendan)

Details

(Keywords: fixed1.8, js1.6)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050906 Firefox/1.4

(I'm not sure what the component of this bug should be.)

In bug 306664, JS 1.6 support was added.  But on 2005090618 branch,

<script type="application/javascript; version=1.6">

doesn't work at all, and

<script language="JavaScript1.6">

works, but E4X support is not enabled.

Reproducible: Always

Steps to Reproduce:
Attached file testcase
Testcase for:
<script type="application/javascript; version=1.6">
<script language="JavaScript1.6">
<script type="application/javascript; e4x=1">
Argh!  I forgot to check in jsapi.c.

However, language="JavaScript1.6" is not working because (see bug 255895) no
other browser respects the version suffix, and language is deprecated.  Please
correct me if I'm wrong, and some other browser ignores tag content (...) for
<script language="JavaScript1.6">...</script>.

This is worth getting right for beta1, and easy to fix.

/be
Assignee: general → brendan
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8b4?
Keywords: js1.6
Priority: -- → P1
Target Milestone: --- → mozilla1.8beta4
Grrr.

I need sleep (again).  Will try tomorrow if there is a respin for 1.8b4.

/be
Attachment #195116 - Flags: superreview?(shaver)
Attachment #195116 - Flags: review?(mrbkap)
Comment on attachment 195116 [details] [diff] [review]
the missing file-patch

sr=shaver
Attachment #195116 - Flags: superreview?(shaver) → superreview+
Comment on attachment 195116 [details] [diff] [review]
the missing file-patch

r=mrbkap
Attachment #195116 - Flags: review?(mrbkap) → review+
Flags: blocking1.8b4? → blocking1.8b4+
Comment on attachment 195116 [details] [diff] [review]
the missing file-patch

we're gonna respin so there's a shot at getting this in if it happens real
soon.
Attachment #195116 - Flags: approval1.8b4+
Fixed brunch and trank.  Er, zzzz (I actually typed that! ;-).

/be
Status: NEW → RESOLVED
Closed: 17 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
David, see comment 2 second paragraph, and the bug to which it links.

/be
Attached file testcase 2
ff 1.4/winxp after today's respin
=================================
application/x-javascript
application/x-javascript;version=1.6
application/javascript
application/javascript;version=1.6
text/javascript
text/javascript;version=1.6
application/ecmascript
application/ecmascript;version=1.6
text/ecmascript
text/ecmascript;version=1.6

msie6/winxp
=================================
text/javascript
text/ecmascript

opera8/winxp
=================================
application/x-javascript
text/x-javascript
text/javascript
text/ecmascript
There is no single test, but the entire js1_6 section run in the browser tests this.
Status: RESOLVED → VERIFIED
Flags: testcase+
You need to log in before you can comment on or make changes to this bug.