The default bug view has changed. See this FAQ.

White line appears at the top of the help window and Error Console (bug 301039 was backed out)

RESOLVED FIXED in Firefox 2 beta1

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: John Hawkins, Assigned: Simon Bünzli)

Tracking

({fixed1.8.1, regression})

2.0 Branch
Firefox 2 beta1
x86
Windows XP
fixed1.8.1, regression
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050907 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050907 Firefox/1.4

Help window now has a 2-3 pixel white line at the top that was not visible in
earlier nightlies.

Reproducible: Always

Steps to Reproduce:
1. Open Help->Help Contents
2. See white line @ top of window
3. File bug report

Actual Results:  
White line appeared.

Expected Results:  
No white line should appear.
(Reporter)

Comment 1

12 years ago
Created attachment 195218 [details]
Screenshot of previously mentioned white line in help dialog
Flags: blocking1.8b5?
Keywords: regression

Comment 2

12 years ago
(In reply to comment #1)
> Created an attachment (id=195218) [edit]
> Screenshot of previously mentioned white line in help dialog
> 

This has been there for months.  It also exists in the JavaScript Console.  I
fixed it in https://bugzilla.mozilla.org/show_bug.cgi?id=301039 but Ben G.
reverted it back by removing that specific fix.  I have no clue as to why he did
that.  No real explanation was given.  

~B
In the default WinXP theme I see only a one pixel white line. Maybe meant as
(reflecting) light?
Screenshot with enlargement: http://img153.imageshack.us/img153/3977/help4ps.png
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Since bug #303806 checkin, help window now shows mysterious white line @ top → white line appears at the top of the help window and javascript console (bug 301039 was backed out)
Version: unspecified → 1.5 Branch

Comment 4

12 years ago
not going to block on this though I'm sure we'd consider a fully reviewed fix if
it's low risk.
Flags: blocking1.8b5? → blocking1.8b5-

Comment 5

11 years ago
The following changes to toolbar.css will fix this issue once and for all!

-  border-top: 2px solid;
-  -moz-border-top-colors: ThreeDShadow ThreeDHighlight;
 }
 
 /* ::::: toolbar & menubar ::::: */
 
 toolbar {
   min-width: 1px;
   min-height: 19px;
   border-top: 1px solid ThreeDHighlight;
   border-bottom: 1px solid ThreeDShadow;
 }
 
 toolbar[type="menubar"], menubar {
   min-width: 1px;
   border-bottom: 1px solid ThreeDShadow;
-  border-top: 0px !important;
+}
+
+toolbox > toolbar:first-child, toolbox > menubar:first-child {
+  border-top: 2px solid;
+  -moz-border-top-colors: ThreeDShadow ThreeDHighlight;
 }

~B

Updated

11 years ago
Summary: white line appears at the top of the help window and javascript console (bug 301039 was backed out) → White line appears at the top of the help window and Error Console (bug 301039 was backed out)
(Assignee)

Comment 6

11 years ago
Created attachment 224684 [details] [diff] [review]
don't assume the first toolbar is always a menubar
Assignee: nobody → zeniko
Status: NEW → ASSIGNED
Attachment #224684 - Flags: review?(kevin)

Updated

11 years ago
Attachment #224684 - Flags: review?(kevin)
Attachment #224684 - Flags: review+
Attachment #224684 - Flags: approval-branch-1.8.1+
Whiteboard: [checkin needed]
Checked this in on the 1.8 branch. Is this relevant to the trunk? It doesn't apply there.
mozilla/toolkit/themes/winstripe/global/toolbar.css 	1.7.2.6
Keywords: fixed1.8.1
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox 2 beta1
Version: 1.5.0.x Branch → 2.0 Branch

Comment 8

11 years ago
(In reply to comment #7)
> Checked this in on the 1.8 branch. Is this relevant to the trunk? It doesn't
> apply there.
> mozilla/toolkit/themes/winstripe/global/toolbar.css     1.7.2.6
> 
I believe this issue does exist on the trunk as well.  I'm not sure if this patch will apply on the trunk though.

~B
(In reply to comment #8)
> I believe this issue does exist on the trunk as well.  I'm not sure if this
> patch will apply on the trunk though.

It won't. That's what I said in comment 7.
(Assignee)

Comment 10

11 years ago
This isn't relevant on the trunk. Should you get the same issue there, please file a regression against bug 313388 (Windows Classic only).
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.