multipart message: parts get shown even when marked as attachments

RESOLVED DUPLICATE of bug 65794

Status

Thunderbird
General
--
minor
RESOLVED DUPLICATE of bug 65794
12 years ago
12 years ago

People

(Reporter: Gustav Tiger, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

When sending an html-mail with an html file attached. Both the message and the
file is showed.. The problem is more visible when using more avanced css
layouts. Text in the attachment gets printed above the mail text etc.

If the attachment is marked with Content-Disposition: attachment the attached
html file should not be show. If it is marked with Content-Disposition: inline
it should though. 

I found this to be an error, or do have I misunderstood the meaning of
Content-Disposition.

Reproducible: Always

Steps to Reproduce:
1. Create a e-mail in HTML format
2. Attach a HTML file with an advance css layout (with position: absolute)
3. Send it to yourself

Actual Results:  
Watch the e-mail.. The attachmend get printed on top of the email text

Expected Results:  
The attachment should not be showed. 

This only occurs if the mime type of the attachment is text/html, if it is
marked as application/octet-stream it will work as expected.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.0

Comment 1

12 years ago
Known bug. Please search before filing new ones (incl. Core bugs).

*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
I don't think this is a duplicate of the bug in question. I was un-aware of that
bug. Originally this bug occured when using a sendmail script in php where I
marked all attachments as 'Content-Disposition: attachment'.

And before trying I though that Thunderbird also sent the attached file as
'Content-Disposition: attachment' when attaching a html file.. That was not the
case as shown by bug 65794.

This bug is not about setting the wrong Content-Disposition when sending but
doing the wrong thing with Content-Disposition when it reads a message. Perhaps
they are both linked to each other but I don't think it is the same bug.

This occurs when reading a mail. The other bug is while sending a mail.

You need to log in before you can comment on or make changes to this bug.