Closed Bug 307790 Opened 17 years ago Closed 16 years ago

popups open in new tab when "Force links.." enabled to open in new tab

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 313300

People

(Reporter: bladeofanduril27, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

When in tab settings "Force links that open new windows to open in:" is enabled
and set to "new tab" popups (allowed or not) open in a new tab instead of a new
windows. Popups aren't links, they should not open in a new tab.

Reproducible: Always

Steps to Reproduce:
1. Tools>Options>Tabs
2. Set "Force links that open new window to open in:" enabled "in new tab"
3. Goto a site with popups that are either allowed or get through the blocker.

Actual Results:  
Popups will open in a tab instead of a window.

Expected Results:  
Popups should open in a window.  User activated links are the only thing that
should be forced to open in a new tab.
*** Bug 311805 has been marked as a duplicate of this bug. ***
In fact, the most interesting feature I've found in 1.5 regarding 1.0 was this open new links in new tabs (also for popups).

Given that it was working very well, is it not possible to add this feature as well?
Isn't this configurable already via browser.link.open_newwindow ?
> Isn't this configurable already via browser.link.open_newwindow ?

It is configurable via browser.link.open_newwindow.restriction. Based on http://kb.mozillazine.org/browser.link.open_newwindow.restriction I believe the options are as follows:

0 = Your "Force links that open new windows to open in:" preferences in Tools-Options determine whether JavaScripts can open new windows or only new tabs.
1 = JavaScripts can always open new windows, no matter what you have set in Tools-Options.
2 = When a JavaScript tries to specify, e.g., that a proposed new window's back/forward/reload buttons are hidden, the status bar is hidden, or the size is purposely smaller, it will open as a window. Otherwise, it will open as a window or as a tab according to your prefs specified in Tools-Options.

The default was changed as per bug 313300, "change default for browser.link.open_newwindow.restriction to 2 (don't divert window.open w/features)" for FF1.5 so I believe this bug should be marked as a dupe of bug 313300.

*** This bug has been marked as a duplicate of 313300 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.