Can't open a link to a local file which has non-ascii characters in the filname

RESOLVED DUPLICATE of bug 311387

Status

()

defect
RESOLVED DUPLICATE of bug 311387
14 years ago
14 years ago

People

(Reporter: zdevir, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.67 KB, application/x-rar-compressed
Details
1.67 KB, application/x-rar-compressed
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Regression in Firefox 1.5, local file links to a non-ASCII7 filename. 
When trying to follow such link, Firefox fails to open the local file. It tries
to open the UTF8 encoding of the url rather than the FileSystem-encoding of the
URL. In fireox 1.0.x, it opened the url with no problems. 
Another aspect of this bug is that the directory listing ("index of ...") cannot
open the files it lists if they are not ASCII-7 encoded.

Reproducible: Always

Steps to Reproduce:
1. Open a local file with non-ASCII-7 link.
2. Try to follow local link.
Actual Results:  
Firefox tries to open UTF-8 encoding of the filename

Expected Results:  
Firefox should open the linked file.

I am using hebrew locale in Win2K. I don't know if this bug exists with other
locales.
(Reporter)

Comment 1

14 years ago
Posted file Small testcase
Sorry for the RAR, but I think (hope) it keeps the original encoding of the
files.
(Reporter)

Comment 2

14 years ago
Posted file A testcase
Sorry for the RAR, but I think (hope) it keeps the original encoding of the
files.

Updated

14 years ago
Version: unspecified → 1.5 Branch

Comment 3

14 years ago
Related to Core bug 284474?
(Reporter)

Comment 4

14 years ago
Setting the "network.standard-url.encode-utf8" preference to false (the default
in the 1.0.x branch), handles non-ASCII-7 URLs as before. So this bug is
probably related to the UTF8 handling of the URI, discussed at bug 284474. 
I'll mark this one as dependent of bug 284474.

Thanks.
Depends on: 284474

Comment 5

14 years ago
The bug also happens under Windows XP with Spanish locale (Firefox 1.0.7). It
happens when double clicking an HTML file or opening it through Start menu
(*.lnk file). It does NOT happen when using drag & drop to open it.
Bug 311387 is dup of this. But it has a patch. Therfore, I mark dup this.

*** This bug has been marked as a duplicate of 311387 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
*** Bug 310880 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.