Cannot open local file from "Index of file://" if its file name contains non-ASCII character (if network.standard-url.encode-utf8 is true)

RESOLVED FIXED in mozilla1.9alpha1

Status

()

defect
P2
normal
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({intl})

Trunk
mozilla1.9alpha1
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

We cannot open local file from "Index of file://" if its file name contains
non-ASCII character. If network.standard-url.encode-utf8 is false, it works fine.
Status: NEW → ASSIGNED
Flags: blocking1.8rc1?
Priority: -- → P2
Posted patch Patch rv1.0 (obsolete) — Splinter Review
This fixes this bug.
Attachment #198715 - Flags: superreview?(darin)
Attachment #198715 - Flags: review?(darin)

Comment 2

14 years ago
The patch for bug 284474 will revert network.standard-url.encode-utf8 to false
as it was for Firefox 1.0.x
Depends on: 284474
Comment on attachment 198715 [details] [diff] [review]
Patch rv1.0

this produces wrong results if the scheme just starts with file...
(In reply to comment #3)
> (From update of attachment 198715 [details] [diff] [review] [edit])
> this produces wrong results if the scheme just starts with file...
> 

That's right. We don't know the scheme, but my code is wrong.
Comment on attachment 198715 [details] [diff] [review]
Patch rv1.0

Darin:

If the pref is set false in default setting, we may not reproduce with default
settings. But this bug is still there. We should fix this bug. Because I cannot
check all checked-in patch. If default pref is changed in a bug which does not
CC'ed me, this bug may be reproduced until bug 278161 is fixed.
Attachment #198715 - Flags: superreview?(darin)
Attachment #198715 - Flags: review?(darin)
Attachment #198715 - Flags: review-
Posted patch Patch rv1.1Splinter Review
Attachment #198715 - Attachment is obsolete: true
Attachment #198798 - Flags: superreview?(darin)
Attachment #198798 - Flags: review?(darin)

Comment 7

14 years ago
Duplicate of bug 308159?
*** Bug 308159 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
Since #308159 was marked as dup of this one, I'd like to extend the scope of the
bug.
This bug influences any link to a local file with a non-ASCII-7 filename.
Directory listing is only once aspect of the bug.
> This bug influences any link to a local file with a non-ASCII-7 filename.

of course, please test the patch.
Now, we cannot reproduce this problem with default settings. But we should fix
this problem on Trunk.
Flags: blocking1.8rc1?
Keywords: regression
Target Milestone: --- → mozilla1.9alpha
Summary: Cannot open local file from "Index of file://" if its file name contains non-ASCII character → Cannot open local file from "Index of file://" if its file name contains non-ASCII character (if network.standard-url.encode-utf8 is true)
Attachment #198798 - Flags: superreview?(darin)
Attachment #198798 - Flags: review?(darin)
Flags: blocking1.9a1?
This is fixed by bug 261929.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Flags: blocking1.9a1?
You need to log in before you can comment on or make changes to this bug.