Right-click on button with onClick fires the onClick event

VERIFIED WORKSFORME

Status

()

Core
Event Handling
P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Henrik Gemal, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When you right-click on a button that has a onClick event the event gets 
activated.

EX: go to:
http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser.
Right-click on "Commit" and your your browser detects a onClick.

This should NOT be the case! Right-clicking on a button should not fire an 
onClick!
(Reporter)

Comment 1

19 years ago
*** Bug 30880 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
This is fixed in the latest windows build.  Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

18 years ago
Also works for me in build 20000501108
Status: RESOLVED → VERIFIED
finally responding to some email i got from mpt [pardon the delay!]: this is not
a problem for me, using 2000.12.07.09 mozilla on win98 [and a 3-button mouse,
fwiw] --however, instead, the context menu appears for a moment, followed by an
alert dialog saying that i need to fill out the summary field [using the test
link above]. if the summary isn't blank, i don't get any alert dialog, and the
context menu appears.

methinks what i'm now seeing this would be a seperate issue --lorca/janc, d'you
know what that bug number would be, if filed already? thx.
QA Contact: janc → lorca

Comment 5

18 years ago
Bug still exists, see bug 71705.
You need to log in before you can comment on or make changes to this bug.