Last Comment Bug 308831 - Tasks no longer appear in view (9-15-2005 nightly)
: Tasks no longer appear in view (9-15-2005 nightly)
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Mostafa Hosseini
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-16 08:42 PDT by J. Perkins
Modified: 2006-01-15 08:58 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description J. Perkins 2005-09-16 08:42:19 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Downloaded 9/15 nightly. Created a new remote calendar (WebDAV) and deleted the
default calendar. Created some events, all good. Tried creating a new task.
Enabled "Task in View", but task didn't appear. Tried switching between all
views. Tried creating a new local calendar and adding the task there, but it
still doesn't appear. Tasks *do* appear in the left-side task pane. Tasks did
appear the last time I tried the calendar (0.2 release).

Reproducible: Always

Steps to Reproduce:
1. Enable "Task In View"
2. Create a new task
3. Switch to multi-week view

Actual Results:  
The tasks did not appear. 

Expected Results:  
It should have displayed the tasks in the multi-week view.

As I mentioned, I started out by creating a remote calendar and deleting the
local one. I don't know if this would have anything to do with it.
Comment 1 J. Perkins 2005-09-16 08:46:58 PDT
I tried deleting the sunbird program directory and also Application
Data/Mozilla/Sunbird and starting from scratch. Even with this clean install the
tasks still do not appear in the view.

Oh yes, I tried setting all combinations of "Date" and "Due Date", no change.
Comment 2 Joey Minta 2005-09-16 11:10:06 PDT
Known issue.  Won't be fixed for 0.3a1.  New views will incorporate this though.
Comment 3 Robin Edrenius 2005-12-24 05:13:30 PST
After the landing of the new views they are shown in Month and Multiweek view, not  the other views though.

Is this because the new views can't show all-day events yet or aren't the tasks supposed to be seen in day- and week-view?
Comment 4 Joey Minta 2005-12-24 06:46:22 PST
(In reply to comment #3)
> Is this because the new views can't show all-day events yet or aren't the tasks
> supposed to be seen in day- and week-view?
> 
calendar-multiday-view.xml discards all tasks before trying to display them, because it only searches for a startDate.  Being able to display allday events would certainly help, but that in itself won't be enough.

Some of the support is there, but more work needs to be done:
http://lxr.mozilla.org/mozilla/source/calendar/base/content/calendar-multiday-view.xml#2131
http://lxr.mozilla.org/mozilla/source/calendar/base/content/calendar-multiday-view.xml#2269

Note that this should probably be done in bug 157274 which is already confirmed.  I suggest that this bug be closed, since it only refers to the regression, which is now fixed.

Comment 5 Robin Edrenius 2006-01-15 08:58:50 PST
(In reply to comment #4)
> Note that this should probably be done in bug 157274 which is already
> confirmed.  I suggest that this bug be closed, since it only refers to the
> regression, which is now fixed.
> 

Resolving as fixed, since it was fixed by the new views.

Note You need to log in before you can comment on or make changes to this bug.