Closed Bug 157274 Opened 18 years ago Closed 14 years ago

ToDo's (task) should be displayed on Week, month ... views

Categories

(Calendar :: Sunbird Only, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: imran.geriskovan, Assigned: jminta)

References

Details

Attachments

(2 files)

ToDo's should be displayed on Week, month ... views
Imran, do you mean that an indicator should appear on days with ToDo items?  In
that case, I would confirm this as normal.  If you mean to show each todo item
like the events are shown, I would confirm this as enhancement.  If you mean
that to-do items need to be visible in all views, then I would mark this works
for me.

The bottom line is, please clarify what you are wanting.
The clafication goes like this: "Show each todo item like the events are shown".
Regards...
This would be more useful if the layout of the week & day views were rearranged
(i've posted suggestions as screenshots in other bugs).
This bug should be more an enhancement. I guess.
Daniel
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: ToDo's should be displayed on Week, month ... views → [RFE] ToDo's should be displayed on Week, month ... views
Someone else can take this if they want.
Assignee: mikep → nobody
*** Bug 165453 has been marked as a duplicate of this bug. ***
OS: Windows 2000 → All
Hardware: PC → All
It's already possible to show tasks in the calendar (View->Tasks in View), 
although its only available for the multi-week view. Since I'm not really in a 
position to do real code work right now, someone else want to grab this one?
Severity: enhancement → minor
Component: Calendar General → Calendar Front End
Summary: [RFE] ToDo's should be displayed on Week, month ... views → ToDo's should be displayed on Week, month ... views
Blocks: cal-views
Blocks: 236405
Blocks: 165505
Depends on: 243020
I do not see what this bug has to do with the location of the "calendars" tab.
No longer depends on: 243020
*** Bug 257631 has been marked as a duplicate of this bug. ***
*** Bug 258626 has been marked as a duplicate of this bug. ***
Suggestion: add 'task' to summary, as they are now called Tasks in the GUI
(en-US), and many duplicate reporters all use 'task'.
*** Bug 259312 has been marked as a duplicate of this bug. ***
Summary: ToDo's should be displayed on Week, month ... views → ToDo's (task) should be displayed on Week, month ... views
Depends on bug 274362: In order to display a task scheduled to a time block long
before the due date, it must have a duration that does not depend on the due date.
Depends on: 274362
It would be useful, that's sure.
The best would be to only show tasks which have a due date of course. Mayba take
a look at kalendar, kde's calendar
*** Bug 274024 has been marked as a duplicate of this bug. ***
*** Bug 296128 has been marked as a duplicate of this bug. ***
I have no idea why there's so much goddamn discussion over this. There's a
checkbox to show the tasks in the calendar, but as soon as you choose another
view  than Multiweek, *poof*, it disappears. What, did Mary Poppins fly in and
whisk it away to a better land?
How is this not a "Severity: Normal" bug?
This should be fixed when bug 297934 lands, check comment #4 on bug 297934
QA Contact: colint → sunbird
Definitely, I think they should be included on daily view also, with the option of not displaying any in "options". That would be awesome. Until then, I have to either write things as "events" or have to navigate and click around to each day, to see what I have for any given day. 
(In reply to comment #19)
> This should be fixed when bug 297934 lands, check comment #4 on bug 297934
> 

Update: now works in month and multiweek view.  Still need to do some work to get them into day/week view, but shouldn't be all that difficult.
It would be helpful if any To Do task with a due date were shown in the calendar. The list on the left should remain but it is useful to see the task in the calendar so you can know what is due on a certain day.
*** Bug 331980 has been marked as a duplicate of this bug. ***
Basic implentation of tasks in the day/week views.  It currently only displays those tasks that have both a start and due date.  Later on, we may want to display tasks that only have one of these dates in a way similar to an all-day event.  (Note that there also is no visual distinction between tasks/events in this patch.)
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #218837 - Flags: first-review?(dmose)
Comment on attachment 218837 [details] [diff] [review]
basic day/week view implementation

>             // if we're about to modify the parentItem, we need to account
>             // for the possibility that the item passed as argument was
>             // some other ocurrence, but the user said she would like to
>             // modify all ocurrences instead.

Context is consent, or something: fix the "occurrence" spellings, and capitalize?

>+        // if we're about to modify the parentItem, we need to account
>+        // for the possibility that the item passed as argument was
>+        // some other ocurrence, but the user said she would like to
>+        // modify all ocurrences instead.

And this one even has your blame on it now!

r=shaver
Attachment #218837 - Flags: first-review?(dmose) → first-review+
Patch checked in.  I'm filing a follow-up bug for visual distinction of tasks vs. events and closing this bug.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
The tooltips displayed in month/multiweek view when you hold the mouse on top of a task are not correct, they report the first event of the view or something like this.
(In reply to comment #27)
This will be fixed by Bug 331145.
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.