RFC 2184 violation w/ attachments containing national characters

RESOLVED DUPLICATE of bug 193439

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 193439
12 years ago
12 years ago

People

(Reporter: Albrecht Dreß, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; de-DE; rv:1.7.6) Gecko/20050405 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; de-DE; rv:1.7.6) Gecko/20050405 Firefox/1.0.2

When attaching a file with national charachters in the file name, e.g. the file

Weired Filename äöüÄÖÜß.dat

Thunderbird creates a MIME header looking as follows:

<snip>
Content-Type: video/mpeg;
 name="Weired Filename =?ISO-8859-15?Q?=E4=F6=FC=C4=D6=DC=DF=2Edat?="
Content-Disposition: inline;
 filename="Weired Filename =?ISO-8859-15?Q?=E4=F6=FC=C4=D6=DC=DF=2Edat?="
</snip>

This contradicts the requirements of RFC 2184 (see
http://www.faqs.org/rfcs/rfc2184.html), section 4. MUA's which stick to RFC 2184
as a consequence will display a broken filename.

A proper encoding according to RFC 2184 would look like

<snip>
Content-Type: video/mpeg;
 name*=iso-8859-1''Weired%20Filename%20%E4%F6%FC%C4%D6%DC%DF.dat
Content-Disposition: inline;
 filename*=iso-8859-1''Weired%20Filename%20%E4%F6%FC%C4%D6%DC%DF.dat
</snip>

Reproducible: Always

Steps to Reproduce:
1. say 'touch "Weired Filename äöüÄÖÜß.dat"'
2. create a message & attach this file
3. read a message with a RFC 2184 compliant MUA, e.g. Balsa (http://balsa.gnome.org)

Actual Results:  
see Details above

Expected Results:  
see Details above
(Reporter)

Updated

12 years ago
Version: unspecified → 1.0

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 193439 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.