Phishing detection no longer works

RESOLVED DUPLICATE of bug 310068

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 310068
12 years ago
12 years ago

People

(Reporter: Ian Neal, Assigned: Scott MacGregor)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Build ID 2005092505 or later
Steps to reproduce
1. Generate an email with a known phishing trigger
2. Open it in Thunderbird or mailnews

Expected result
1. Message bar shows it as a scam/phishy

Actual result
1. Message bar does not change

Works fine in BuildID 2005092405 or earlier

Using JS debugger with mailnews seems to show the for loop

var anchorNodes = msgDocument.getElementsByTagName("a");
for (var index = 0; index < anchorNodes.length && !isEmailScam; index++)
  isEmailScam = isPhishingURL(anchorNodes[index], true);

not getting past index = 0 with isEmailScam being false

only checkins in that period seem to be do with DOM: Core - nothing TB/mailnews
related.
(Assignee)

Comment 1

12 years ago
branch or trunk ian?
(Reporter)

Comment 2

12 years ago
trunk
(Reporter)

Comment 3

12 years ago
The other alternative is /be's jsinterp.c changes which have had some regression
fixes put in, but I've just tested
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/tinderbox-builds/patrocles-trunk/
which should have them in and it still does not work.
(Assignee)

Comment 4

12 years ago
anchorNodes.length is coming back as undefined for me even though the document
clearly has several anchor elements.

I think this call isn't working:

var msgDocument = document.getElementById('messagepane').contentDocument;
var anchorNodes = msgDocument.getElementsByTagName("a");
Depends on: 310068

*** This bug has been marked as a duplicate of 310068 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.