Quoted plain text size have no effect.

VERIFIED FIXED in M17

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: laurel, Assigned: rhp (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using 2000-03-07-09m15 commercial builds: NT 4.0, linux rh6.0 and mac OS 9.0

Quoted plain text styles and sizes do not reflect in displayed message, although
the prefs enable, stick and are written to prefs.js file.

1.  Go to mail window.  Set your account setting for plain text message compose
window. 
2.  Edit|Prefs|Mail and Newsgroups. Change the "Quoted plain text appearance"
prefs for style and size to Bold/Bigger. OK to confirm change.
3.  Send yourself a plain text message, get it and reply to it (with quoting
on).
4.  Get the reply and notice the quoted plain text is not in specified style. 
5.  Repeat to try all options of style and size -- none of the options (other
than regular) work.

Note:  I'm not sure if this is because the quoting character ">" isn't present
-- the quoting character is a blue line when displayed (ref bug #31045).
(Reporter)

Comment 1

18 years ago
Quoting styles and sizes do not display even on messages which do indeed display
chevron as quoting character (message is not format=flowed).

Comment 2

18 years ago
Right. I don't think format=flowed has anything to do with the size/style of the
quoted material. Format=flowed does change the way we show the message is quoted
in that we made format=flowed using HTML-style <blockquote>, rather than plain
text-style '>'. I don't agree with that decision, but that's life...

Comment 3

18 years ago
Oh, yeah, and assigning to rhp and cc'ing Ben B since they were kicking around
implementation ideas for this using CSS.
Assignee: phil → rhp
(Reporter)

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 4

18 years ago
Just so I'm clear, the CSS implementation I'm referring to is for
coloring/sizing quoted text. I'm not suggesting a CSS workaround for making
<blockquote> look like '>'. I'd certainly be interested in that :-) , but let's
constrain this bug to the size/color of quoted text.

Comment 5

18 years ago
IMO the best way to achive this would be a stylesheet editor, but that's too far
away.

I suggest, we add a wrapping tag for the quote. 4.x just added the formatting as
HTML tags, e.g. it inserted "<font size="-1">" etc. around every line in the
quote. We could just add a tag around the whole quote and another one, this time
with a class attribute, around the whole msg and then write a style-tag with an
inline-stylesheet at the beginning of the msg.

Later, when we can edit external stylesheets, we can throw the style-tag out of
libmime and let the prefs UI write to messenger.css. That way, libmime wouldn't
have to care about the prefs at all.

This may make it possible to overwrite the hardcoded formatting with arbitary
user-specified CSS formatting using some CSS tricks. I.e. advanced users are not
limited to the formatting options we offer in the UI.

I suggest, we use "blockquote" as wrapping class around the quote, "div" around
the whole msg and the following class names for the div: "text-plain" and
"text-flowed". Due to the freedom of CSS, we can then emulate the behaviour of
4.x.

A sample msg (illustration, can be more efficient in production):
<head><!-- ... --></head>
<style>
  div.text-plain
  {
    whitespace: pre;
    font-family: serif  /* this user enabled variable-width-fonts */
  }
  div.text-flowed
  {
    whitespace: pre;
    font-family: serif  /* this user enabled variable-width-fonts */
  }
  div.text-plain blockquote
  {
    /* first, disable the default settings. awful :-( */
    margin: 0em 0em;
    padding-left: 0em;
    border-left: none;
    /* now the real formatting */
    font-style: italic;
    font-size: smaller;
    color: red
  }
  div.text-flowed blockquote
  {
    border-width: thin;
    border-color: black
  }
</style>
<body>
<div class=text-plain>
Somebody Else wrote:
<blockquote type=cite>
> This is the quote
</blockquote>

This is the new text of the msg
</div>
</body>
(End of example)

This also eliminates the "<PRE style="...">"-tag around the msg, which we
currently use for variable width fonts.

So far, implementation should be easy and straighforward. But note, that we
currently don't even /recognize/ quotes. This was done in ScanForURLs in 4.x,
but was disabled in Mozilla. When I rewrote this function (now
mozTXTToHTMLConv:ScanTXT), I moved the functionality into an extra function
(mozTXTToHTMLConv:CiteLevelTXT), but it is currently unused and untested.

rhp, if you're going to start implementation, we can discuss this in more
detail.

Open CSS problems:
- Overwriting the default style for "blockquote[type=cite]" in ".text-plain
blockquote" is bad style.
- The style tag could be converted in a link to a stylesheet, e.g. encoded in a
"data:"-URL.
(Assignee)

Comment 6

18 years ago
Ben, you want this bug?

- rhp

Comment 7

18 years ago
heh, no tnx. I leave the fun of the implementation and especially testing to you
*g*. Seriously, there're too many string pointers for my taste in mimetp*.cpp
and I also don't have that much time currently (basically I have no time at all
for Mozilla, but I can't hold back sometimes :-) ).

Comment 8

18 years ago
Some very limited demo (no pref query, also needs clenup) for format=flowed is
attached to bug #29557.
(Assignee)

Comment 9

18 years ago
Ok, I spent some time on this and I think that I have it functional as 4.x.

- rhp
Status: NEW → ASSIGNED
Summary: Quoted plain text style/size have no effect. → [FIXED] Quoted plain text style/size have no effect.
Target Milestone: M15

Comment 10

18 years ago
Because of time constraints, rhp did not implement my proposal to use
stylesheets. I'm currently reimplementing (with his rhp's agreement). ACCEPTing.

Phil,
you won't like, what I did *g*. A more or less side-effect of customizability by
stylesheets was the possibility to replace text quote tags (e.g. "> ") by
graphical ones (e.g. the blue bar). Of course, this will be a pref. The bars can
look differently depending on the type of the msg, and propably will do so by
default (if no one objects).

My questions to the Mailnews team:
- Will I get UI for the pref? It would read something like "Show graphical
instead of text quote tags (e.g. "> ") for normal plain text msgs".
- What should be the default?
Summary: [FIXED] Quoted plain text style/size have no effect. → Quoted plain text style/size have no effect.

Comment 11

18 years ago
REASSIGN
Assignee: rhp → mozilla
Status: ASSIGNED → NEW

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 12

18 years ago
Ben, 
Note my question of 2000-03-08 18:01...."Ben, you want this bug?". You answered 
"NO" so I got a solution running. Now you want the bug because you don't 
like what I've done??? You've basically wasted about 4 hours of my time on a 
Saturday evening because of this. 

I am not happy about this! Look, when shit breaks in libmime, its my ass on the 
line. We are PAST beta 1...which means that time getting VERY SHORT. I can't 
afford another time sink like the one that went into the TXT to HTML converter. 
I am taking this bug back.

In the future, if I ask you a question, remember you must live by your answer.

- rhp
Assignee: mozilla → rhp
Status: ASSIGNED → NEW

Comment 13

18 years ago
Huh? You wrote:

> this is not all CSS based but rather functionality that matches 4.x. If you

> want to change that, you can take the bug, but this is all I have time for

> now.



Sometimes, I get weak and care about things, that I maybe should not care about...



So, what now? I'm working >10 hours on my version now (including the patch in

the flowed bug).



What I have:

- quotes are recognized as blocks (i.e. one tag around the whole quote, not

every line)

- nested quotes are supported

- stylesheets for both the whole msg and the quotes are working



What I do not have:

- 4.x functionality (I can use your changes for that, so your time isn't wasted)

- The pre tag makes problems together with stylesheets. I need to investigate.

(Assignee)

Comment 14

18 years ago
Ben, 
When you say "I'm currently reimplementing", this does not sound like you are 
using my work and enhancing. This sounds like you are throwing away what I've 
done and starting over. This is what upset me. If you want to build on what 
I've done, that is one thing, but I did not get that impression from your 
comments.

Please clarify what you intend to do.

- rhp

Comment 15

18 years ago
rhp,

my proposal was to write the styling information in the <head> section (in a

"<style>" element) instead of writing it into the "style" attribute of every

quote tag, and I intended to change the implementation to do that. However, I

did not know, what was the right place in libmime, and it depends on the

"condensed" quote tags (see my last comment), so I started with the latter.



Now you said, that it upsets you, that I wanted to reimplement the styling, so I

changed my plan and decided to use your changes.

(Assignee)

Comment 16

18 years ago
My whole point is that you told me you didn't have the time to deal with the 
issue, so I completed the work. Writing style information into a <HEAD> section 
(which, by the way doesn't currently exist with plain text message display) 
would be a nice thing, but with respect to fixing this bug as it is stated, 
it's not a huge difference. (Note: my changes do recognize quotes as 
blocks...NOT every line...they do this for both format=flowed and plain text)

What you have spent time on is a lot of functionality that falls outside the 
realm of making this work like it did in 4.x. That's great, but keep in mind, 
we are past beta1 and I have less and less time every day for stuff that is not 
on my current "to-do" list. 

I love all the work that you have done for us, but any change that is 
contributed to me as a module owner requires the following:

 - Merge into my development tree on Win32 (since this is my primary platform)
 - Verify building on Win32
 - Test on Win32 (keep in mind all I18N issues)
 - Create Patch Files for Linux
 - Patch, Build and Test on Linux
 - Copy changes (entire file copies) to Mac (Mac doesn't support patch)
 - Rebuild on Mac
 - Test on Mac
 - Prepare checkins to go into tree
 - Checkin and watch tree to insure no breakage

When I write the code, I handle this all as I go. For this bug, I have all of 
the above complete, but if you want to contribute a lot of new 
code/functionality, I have to restart at Step #1. For this issue, since I 
already completed the basic functionality, it doubles my work. I did not have 
this in my plan and I am very sensitive to getting work on my plate that I did 
not have time to properly plan for.

I hope you can understand my points.

- rhp

Again, I appreciate all of your work, but keep in mind that when you give me 
changes to go into the 
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 17

18 years ago
> my changes do recognize quotes as blocks...NOT every line...

Yes, you're right, I overlooked that.

I know, that it takes lot of time to test the changes, and I thank you for doing
this work for me. I wish, I could do it by myself, but Mozilla.org doesn't have
the necessary intrastructure. There's an proposal for it, tough.

I also understand, that you don't like wasting your time, I feel the same way.
Sorry, if I did.

Updated

18 years ago
Depends on: 31744

Updated

18 years ago
Depends on: 30127
No longer depends on: 31744
(Assignee)

Comment 18

18 years ago
Just checked in my fix for this issue.

- rhp
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
OK, filed bug #31906 for my enhancements.

Phil, please post the decision about the new pref for graphical quotes to the
new bug.
(Reporter)

Comment 20

18 years ago
*** Bug 32520 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
Rich says he checked in his fix on 3/14, but in the 3/22 build I'm still seeing
quoted text in a much smaller font than unquoted text, and changing the pref for
font size for quoted text has no effect.  Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 22

18 years ago
Akkana: you're using the 3/22 tip build, not the beta branch, right?

Comment 23

18 years ago
Correct, the place where I'm seeing this is on the tip, not the beta branch.
(Assignee)

Comment 24

18 years ago
Will investigate later.

- rhp
Status: REOPENED → ASSIGNED
Summary: Quoted plain text style/size have no effect. → Quoted plain text size have no effect.
Target Milestone: M15 → M17

Comment 25

18 years ago
Requesting beta2 consideration, because the current fixed size is too small to
read easily.  If it were the same size as the quoted text, I wouldn't mind so
much not being able to change it. 
Keywords: beta2

Comment 26

18 years ago
akk, however PDT might rate it, I'll take at look at it for M16 with bug #31906.

Comment 27

18 years ago
akk, worksforme. Can you please describe detailed, what you're seeing for which
msgs and what your prefs are for quoting style, mail font family (variable or
fixed width) and x-unicode fonts?

Comment 28

18 years ago
Rich, do you mind, if I take this bug (i.e. the bug akk mentioned)?
(Assignee)

Comment 29

18 years ago
Sure...go for it. Keep in mind, now that a beta1 is just about out the door...I 
am very very very scared of major rewrites in libmime.

- rhp

Comment 30

18 years ago
Created bug #33305 for the bug akk mentioned, since it seems to be a different
problem. Taking beta2 over. Marking this one FIXED again.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Keywords: beta2
Resolution: --- → FIXED

Comment 31

18 years ago
Note that it's still the case that the preferences for style, size, and color
have no effect on what is displayed in the message.  But if you want to track it
with another bug rather than this bug, I guess that's your choice.
(Reporter)

Comment 32

18 years ago
I have no grasp on all the banter of comments in this bug which caused bug
#33305 to be opened... however, I find that changing size or style for quoted
text prefs does reflect using the builds listed below, so will mark this bug
verified.  Color still doesn't work, but that is covered with bug #29727.

Using:
2000-04-24-09m16 commercial build linux rh6.0
2000-04-21-09m16 commercial build NT 4.0
2000-04-24-08m16 commercial build mac OS 9.0

Will cc: pmock now that he's back from sabbatical since this is his QA area and
he can work with #33305.
Status: RESOLVED → VERIFIED

Comment 33

18 years ago
If I change style to italic, then I can now see quoted text at regular size
(yay!) if I set the size to regular.  Setting size to small does make it
smaller; but setting size to larger does not make it larger (it's still the same
size as the unquoted text).

Maybe this is some weirdness in my italic font?  I'm curious whether this
happens on anyone else's machine.  If it's just mine (RH 6.0 with no unusual
fonts installed), then it's no big deal since what I wanted was italic/regular
size, and I have that now.

Comment 34

18 years ago
*** Bug 29727 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.