Closed Bug 310526 Opened 17 years ago Closed 17 years ago

javascript pop-ups fail with "uncaught exception" after browser open for a while

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 309775

People

(Reporter: bugzilla, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20050926 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20050926 Firefox/1.4

After having my browser open for a while, javascript pop-ups stop working.  If I
restart Firefox, that same page will work, but about 30 minutes later it won't
(and neither will any other js pop-ups).  This happens when I have pop-up
blocking turned on or off.

Reproducible: Sometimes

Steps to Reproduce:
1. Actively use browser for 30+ minutes
2. Go to this url: http://www.amazon.com/exec/obidos/tg/detail/-/B0003009AI/
3. Click on the image of the product (to see bigger version)

Actual Results:  
Nothing happens (just error in js console)

Expected Results:  
Window should pop-up

Javascript console output:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
http://www.amazon.com/exec/obidos/tg/detail/-/B0003009AI/qid=1128043066/sr=8-11/ref=pd_bbs_11/002-3702695-2654447?v=glance&s=electronics&n=507846
:: amz_js_PopWin :: line 8"  data: no]

These bugs might be the same problem, but I couldn't reproduce them with the
info given in their bug reports:

https://bugzilla.mozilla.org/show_bug.cgi?id=250749
https://bugzilla.mozilla.org/show_bug.cgi?id=281110
https://bugzilla.mozilla.org/show_bug.cgi?id=299461

*** This bug has been marked as a duplicate of 309775 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.