Closed Bug 310547 Opened 16 years ago Closed 15 years ago

Wrong handling of addresses that have an encoded comma in the recipient's name

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: szymans, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla Thunderbird version 1.0.7 (20050923)

When I receive an e-mail with multiple recipients and some of them have national
characters and a comma inside written like that:
To: =?iso-8859-2?Q?P=B3aszczka=2C_Anna?= <abcd@efgh.ijkl.opq>,
	<xyz@aa.bb>

Thunderbird interprets a comma in the iso-encoded address and handles this
address as two:
Plaszczka (WITHOUT real e-mail address)
Anna <abcd@efgh.ijkl.opq>

When choosing Reply-All this results in send errors since some recipients do not
have a valid e-mail address.

This kind of addresses seems to be produced repeatedly by:
X-MimeOLE: Produced By Microsoft Exchange V6.5.7226.0
where the administrator decided to use real user names like that:
Surname, Firstname

Reproducible: Always

Steps to Reproduce:
1. You need to receive a "properly" formatted e-mail with one of the recipients
encoded like that:
To: =?iso-8859-2?Q?P=B3aszczka=2C_Anna?= <abcd@efgh.ijkl.opq>
2. Observe recipients list when viewing the email
3. Try to reply-all

Actual Results:  
Two recipients appear instead of one:
Plaszczka
Anna <abcd@efgh.ijkl.opq>

Expected Results:  
Only one recipient with quoted 
"Plaszczka, Anna" <abcd@efgh.ijkl.opq>
should appear.
Duplicate of Core bug 254519?
Yes, a dupe.

*** This bug has been marked as a duplicate of 254519 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.