ASSERTION: forget-word-frame: '(void*)aFrame == mWordFrames->PeekFront()' involving empty generated content

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86
Windows XP
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

164 bytes, application/xhtml+xml
Details
7.49 KB, text/plain
Details
(Reporter)

Description

13 years ago
 
(Reporter)

Comment 1

13 years ago
Created attachment 197977 [details]
testcase
What's the actual full assertion text?  And the top 5-6 stack frames?
(Reporter)

Comment 3

13 years ago
###!!! ASSERTION: forget-word-frame: '(void*)aFrame == mWordFrames->PeekFront()'
, file c:/buildmoz/mozilla/layout/generic/nsLineLayout.cpp, line 3033
(Reporter)

Comment 4

13 years ago
Created attachment 198026 [details]
stack trace
Hmm.  So aFrame is a text frame for two newlines, but mWordFrames->PeekFront()
is the zero-length text that content: inserts here.  roc, dbaron, any idea
what's going on?
Blocks: 311812
Blocks: 323986
Jesse, do you still see this?  I can't seem to reproduce now...
(Reporter)

Comment 7

11 years ago
WFM on Mac trunk.  I guess I should test Windows too, since I reported it on Windows.
Works for me on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042315 Minefield/3.0pre ID:2008042315 - i don't see such a assertion when i load the testcase

-> WFM
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Please check the testcase in?
Flags: in-testsuite?
(Reporter)

Comment 10

11 years ago
I checked the testcase in as a crashtest.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.