cibc.com - CIBC online banking "Sign On" button does nothing.

VERIFIED DUPLICATE of bug 309348

Status

Tech Evangelism Graveyard
English Other
VERIFIED DUPLICATE of bug 309348
13 years ago
3 years ago

People

(Reporter: Jason Bassford, Unassigned)

Tracking

({ecommerce, regression})

Details

(URL)

(Reporter)

Description

13 years ago
I'm not actually certain if this is a problem with code changes in Mozilla, or a
change to the site code itself.  I'm filing it under Tech Evangelism for now.  

When I have time to test an older browser version (I know that this worked a
couple of weeks ago) or to try with a new profile (although nothing in my
current one has chanted).  I'll update this bug and/or change the product
accordingly when I do - I just wanted to get this bug in place while I
remembered to do so.

In any case:

1. Go to the URL.
2. Enter whatever you want for username and password.
3. Click on "Sign On".

Nothing at all happens.  It's as if you never clicked.  It doesn't matter if you
enter something valid or not.
(Reporter)

Comment 1

13 years ago
Okay.  I tested with a 9/10 build - the "Sign On" button still had no effect.  I
also tried with a new profile (under 9/10) - still nothing.

So, it's definitely not a Mozilla code change here.  Something has been modified
in the site code to break Mozilla (perhaps only Seamonkey - I didn't test with
Firefox, although I'd be really surprised if it worked) functionality.

Tech Evangelism is the correct product.

Note that the JavaScript Console is showing CSS declaration errors.  Most of
these are in relation to "padding" or "margin", but "z-index" and "position"
being dropped *might* be related to what's happening (although I'm skeptical).

I don't know enough to go through the site code to figure out anything more at
this point...

(Reporter)

Comment 2

13 years ago
Fixing Summary.  (I should have known better.)

Regression window (that I can verify):

Worked on 9/17.  Didn't work on 9/27.  (I can't narrow it down any more.)
Summary: CIBC online banking "Sign On" button does nothing. → cibc.com - CIBC online banking "Sign On" button does nothing.

Comment 3

13 years ago
I don't think this is tech evangelism. The signon works in Firefox 1.0.7 but not
Firefox 1.4 or Firefox 1.6a1 on WinXP.
(Reporter)

Comment 4

13 years ago
As I said, everthing worked fine for me two weeks ago.  I went back to a two
week old build (that had worked before) and now it no longer does.  There may
also be code differences involved between Seamonkey and Firefox that are
responsible - but the same Seamonkey build that used to work doesn't any more...

However, once the actual root cause of this can be identified, it will be easier
to determine if it's something that needs to be addressed in our code, or if
it's something that that site's done that should be corrected.

(I'm happy to put this bug whereever it belongs, so long as I can do my banking
again without resorting to IE. <grin>)
Looks like a duplicate of bug 309348...

*** This bug has been marked as a duplicate of 309348 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

13 years ago
Thanks, Blake!
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.