Last Comment Bug 309348 - form will not submit when clicking the submit button
: form will not submit when clicking the submit button
Status: RESOLVED FIXED
[HAVE FIX]
: fixed1.8, regression, testcase
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: All All
: -- major with 2 votes (vote)
: mozilla1.8beta5
Assigned To: Johnny Stenback (:jst, jst@mozilla.com)
:
: Jet Villegas (:jet)
Mentors:
https://www.cibconline.cibc.com/olbtx...
: 310561 310876 311319 (view as bug list)
Depends on: 234455
Blocks: 277890
  Show dependency treegraph
 
Reported: 2005-09-20 10:12 PDT by jason
Modified: 2014-06-24 01:10 PDT (History)
20 users (show)
mconnor: blocking1.8b5+
pavlov: blocking1.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Simple page demonstrating bug (415 bytes, text/html)
2005-09-26 08:57 PDT, Taylor Mathewson
no flags Details
Fix (1.49 KB, patch)
2005-09-29 15:36 PDT, Johnny Stenback (:jst, jst@mozilla.com)
bryner: review+
bzbarsky: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description jason 2005-09-20 10:12:38 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

when filling out the form fields (does not need to be valid info) the submit
button will not submit. pressing <enter> on password field will not submit either.

Reproducible: Always

Steps to Reproduce:
1. fill in card number field
2. fill in password field
3. press submit

Actual Results:  
nothing

Expected Results:  
the form should submit and the data (card/password) should be validated

i work for cibc online banking. you can contact me at jason.seto@cibc.com for
more information.
Comment 1 Phil Ringnalda (:philor) 2005-09-20 11:23:07 PDT
I just get a 404 Not Found from that URL - is it wrong, or do we need to get
there from another page, or already be authenticated some other way?
Comment 2 Peter van der Woude [:Peter6] 2005-09-20 11:25:09 PDT
1. do you see any messages in the javascript console if you press submit ?
2. did it work with previous Firefox versions ?
Comment 3 jason 2005-09-20 11:50:35 PDT
yes, this works with 1.0.6 which i am using now, as well as IE and other ****
browsers.
Comment 4 Gérard Talbot 2005-09-20 12:13:13 PDT
I've examined the page code and am not sure why the form is not submitted. But I
certainly would code the page differently, in several areas; there are many
wrong coding practices and errors in that page...

How about coding (line 467):
<input type="submit" value="Sign On" class="calloutButton"
onsubmit="clickedSignOn = true;" onMouseOut="clickedSignOn=false;" tabindex="4">

and then getting rid of the doSignOn() (line 147) entirely?
Comment 5 Gérard Talbot 2005-09-20 12:22:02 PDT
Correction: it *is* submitted and validated. Firefox 1.4 rv: 1.8b4 build
20050918 under XP Pro SP2 here.

My other comments still remain: there are much better coding practices to code
several areas of the pages involved.
Comment 6 Taylor Mathewson 2005-09-26 08:57:00 PDT
Created attachment 197421 [details]
Simple page demonstrating bug

I've attached a simplified page demonstrating the bug.	This appears to be a
re-emergence of (or at least very similar to)
https://bugzilla.mozilla.org/show_bug.cgi?id=242494
Comment 7 jason 2005-09-26 09:51:00 PDT
here is the URL to use to verify this bug:
https://www.cibconline.cibc.com/olbtxn/authentication/PreSignOn.cibc?locale=en_CA
Comment 8 Mike Beltzner [:beltzner, not reading bugmail] 2005-09-26 10:43:03 PDT
Confirmed. At the URL provided in comment 7, hitting "Submit" gives me nothing
using (Gecko/20050920 Firefox/1.4), but works fine (returns an error) using
Firefox 1.0.6.
Comment 9 Mike Connor [:mconnor] 2005-09-26 20:38:23 PDT
We really need a regression window on this, should be fairly easy... I hope.
Comment 10 Phil Ringnalda (:philor) 2005-09-26 21:18:39 PDT
Some time before Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5)
Gecko/20041018 Firefox/0.9.1+, which is as far back as I have trunk builds.
Comment 11 Dean Tessman 2005-09-28 14:01:22 PDT
(In reply to comment #10)
> Some time before Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5)
> Gecko/20041018 Firefox/0.9.1+, which is as far back as I have trunk builds.

Really?  This was working for me (I'm a CIBC online banker) up until a week or
two ago - roughly.
Comment 12 IU 2005-09-29 00:31:47 PDT
I too can confirm this bug.  I have tested with the latest Branch and Trunk
builds and this is a problem.  I have also tested with Branch builds going back
as far as 20050912 (the earliest for which I can find binaries) and it still
does not work.  However it does work with 1.0.7

Note: I believe that CIBC may have changed their script not much more than a
week or so ago, because I am absolutely positive that I have successfully logged
into the site within that timeframe, using a Branch build that should not have
been greater than 3 days out of date.  Thus, it does not appear to be a
regression per se.  Nonetheless, it no longer works - except with the Official
build.
Comment 13 Uri Bernstein (Google) 2005-09-29 11:56:42 PDT
This broke on the trunk between 2004-04-30-08 and 2004-05-02-08 (couldn't find
any builds in between).
The most likely candidate for breaking this is bug 60212.
Comment 14 Asa Dotzler [:asa] 2005-09-29 12:56:29 PDT
Johnny, we need more of your help here.
Comment 15 Johnny Stenback (:jst, jst@mozilla.com) 2005-09-29 15:36:36 PDT
Created attachment 197917 [details] [diff] [review]
Fix

This fixes this bug. The problem is that the click event handlers here prevent
the default action, which ends up preventing us from firing the NS_UI_ACTIVATE
event, which is what's expected to flush the pending form submission. So in
this case we end up never flushing pending form submissions...
Comment 16 Boris Zbarsky [:bz] (still a bit busy) 2005-09-29 19:54:39 PDT
Comment on attachment 197917 [details] [diff] [review]
Fix

I guess this is ok, but I'd prefer something more like the nsHTMLInputElement
logic, which has a boolean outerActivateEvent that it uses to trigger this
case... Could you do that here too, please?
Comment 17 Blake Kaplan (:mrbkap) 2005-09-30 12:48:09 PDT
*** Bug 310561 has been marked as a duplicate of this bug. ***
Comment 18 Jason Bassford 2005-09-30 13:03:35 PDT
This has to be one of the stranger bugs I've seen to pin down to a product.  I
agree with comment 12 - and had filed a duplicate of this under Tech. Evangelism
because of that.  The very same build, 2 weeks ago, that *definitely* worked on
the CIBC site at that time fails to work today.  (After having gone back to it
for testing.)  Since it's exactly the same browser code, the only variable has
to be that the CIBC site code has changed in the past 2 weeks - which has likely
only just now exposed a rather long-lasting bug in Seamonkey (comment 14).
Comment 19 Johnny Stenback (:jst, jst@mozilla.com) 2005-09-30 15:53:07 PDT
(In reply to comment #16)
> (From update of attachment 197917 [details] [diff] [review] [edit])
> I guess this is ok, but I'd prefer something more like the nsHTMLInputElement
> logic, which has a boolean outerActivateEvent that it uses to trigger this
> case... Could you do that here too, please?
> 

I can, but I'll land this as is first, and I'll do the other changes later on
for the tunk only.
Comment 20 Johnny Stenback (:jst, jst@mozilla.com) 2005-09-30 16:20:02 PDT
Fix landed on trunk and branch, leaving bug open to do the cleanup on the trunk.
Comment 21 Phil Ringnalda (:philor) 2005-10-02 19:42:17 PDT
*** Bug 310876 has been marked as a duplicate of this bug. ***
Comment 22 Dean Tessman 2005-10-04 08:28:26 PDT
I can log in to CIBC now, but I can't submit a search on Air Canada's web site.
 Is this related?

http://www.aircanada.com/en/home.html

Then try to search in the Book a Flight section.  Looks very similar to the
symptoms of this bug.
Comment 23 IU 2005-10-04 09:18:51 PDT
(In reply to comment #22)
> I can log in to CIBC now, but I can't submit a search on Air Canada's web site.
>  Is this related?
> 
> http://www.aircanada.com/en/home.html
> 
> Then try to search in the Book a Flight section.  Looks very similar to the
> symptoms of this bug.

WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051003
Firefox/1.4.1 ID:2005100307

Have you tested with a clean profile?
Comment 24 Dean Tessman 2005-10-04 09:43:25 PDT
Tried it with a clean profile but it's no different.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051004
Firefox/1.6a1
Comment 25 jason 2005-10-04 10:15:20 PDT
the original bug with the cibc.com site has been fixed in the build i just
retrieved:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051004
Firefox/1.6a1
Comment 26 IU 2005-10-04 10:27:30 PDT
(In reply to comment #24)
> Tried it with a clean profile but it's no different.
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051004
> Firefox/1.6a1

I can confirm your bug.  Deer Park 20051003 works, but 20051004 fails.  Even the
language selection dialog (non-Canadian residents may not see this), in the
absence of a previous cookie, fails.
Comment 27 IU 2005-10-04 10:46:46 PDT
Ahem... Sorry to spam the board.  I was in error when I wrote "Even the
language selection dialog (non-Canadian residents may not see this)."  Everyone
will see it, because it's a country selection page! :-)

FYI, cibc.com is still okay.  It's just aircanada.com that is now b0rk3d.
Comment 28 Boris Zbarsky [:bz] (still a bit busy) 2005-10-04 14:56:25 PDT
jst, this was basically a dup of bug 277890, right?  I guess we should dup that
one forward to here...
Comment 29 Phil Ringnalda (:philor) 2005-10-06 08:32:52 PDT
*** Bug 311319 has been marked as a duplicate of this bug. ***
Comment 30 Stuart Parmenter 2006-09-07 15:21:31 PDT
still needs cleanup on the trunk.
Comment 31 Boris Zbarsky [:bz] (still a bit busy) 2006-09-07 15:23:11 PDT
Resolving fixed.  Bug 277890 is now tracking the remaining cleanup.

Note You need to log in before you can comment on or make changes to this bug.