Last Comment Bug 310840 - Crash in XFormsInsertDeleteElement
: Crash in XFormsInsertDeleteElement
Status: RESOLVED FIXED
: fixed1.8
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
: Stephen Pride
Mentors:
: 312347 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-02 12:07 PDT by Olli Pettay [:smaug]
Modified: 2016-07-15 14:46 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed patch (1.38 KB, patch)
2005-10-02 12:13 PDT, Olli Pettay [:smaug]
allan: review+
aaronr: review+
Details | Diff | Splinter Review

Description Olli Pettay [:smaug] 2005-10-02 12:07:44 PDT
I got a crash in the following place.
0xb360607c in nsXFormsInsertDeleteElement::HandleAction (this=0xa3c21d8,
aEvent=0xa14ef78, aParentAction=0x0) at nsXFormsInsertDeleteElement.cpp:195

Patch coming.
Comment 1 Olli Pettay [:smaug] 2005-10-02 12:13:12 PDT
Created attachment 198243 [details] [diff] [review]
proposed patch
Comment 2 aaronr 2005-10-03 18:06:53 PDT
Comment on attachment 198243 [details] [diff] [review]
proposed patch

could you please attach a testcase?  Makes it a lot easier to test whether a
bug made it in to the branch patches if each bug in the patch has a testcase. 
Thanks.
Comment 3 Allan Beaufour 2005-10-03 23:48:10 PDT
Checked in to trunk. Leaving open for branch and testcase.
Comment 4 aaronr 2005-10-13 12:59:04 PDT
*** Bug 312347 has been marked as a duplicate of this bug. ***
Comment 5 Doron Rosenberg (IBM) 2005-10-21 09:16:33 PDT
checked into branch.

Note You need to log in before you can comment on or make changes to this bug.