Crashes when displaying image

RESOLVED DUPLICATE of bug 210931

Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED DUPLICATE of bug 210931
13 years ago
10 years ago

People

(Reporter: Wolf Wiegand, Assigned: blizzard)

Tracking

({crashreportid})

1.7 Branch
x86
Linux
crashreportid

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050925 Firefox/1.0.4 (Debian package 1.0.4-2sarge5)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050925 Firefox/1.0.4 (Debian package 1.0.4-2sarge5)

Firefox crashes if one navigates to http://www4.infi.net/~cpinkham/gyach/. If I
change my preferences not to display any images, ff doesn't crash. 

Reproducible: Always

Steps to Reproduce:
1.Enable displaying of images
2.Go to http://www4.infi.net/~cpinkham/gyach/

Actual Results:  
ff crashes, ie. it just disappears

Expected Results:  
don't crash

Comment 1

13 years ago
WFM on branch, tested with [Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8b5)
Gecko/20050930 Firefox/1.4].
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 (No
IDN) Firefox/1.0.6
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051001
Firefox/1.4.1 ID:2005100107

No crash with these two builds.

Reporter, can you please test with Firefox running in safe-mode
 http://kb.mozillazine.org/Safe_mode
(Reporter)

Comment 3

13 years ago
Same behaviour in safe mode.

After some further testing, I am starting to think of this as a debian bug. I've
just asked fellow debian users about their experience with both the debian
package as well as the version straight from mozilla.org and am awaiting their
answers.

With 1.0.7 running on a BSD, I cannot reproduce the behaviour, either. I can
reproduce the crash with a different user whose .mozilla directory has been
removed before starting ff (using safe mode, too).

On the console, I get the following:

wolf@thinkpad:~ $ firefox -safe-mode
*** loading the extensions datasource
*** loading the extensions datasource
The program 'firefox-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 20431 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

The "X Window System error" puzzles me... The page loads allright in opera, though.

Comment 4

13 years ago
(In reply to comment #3)

> After some further testing, I am starting to think of this as a debian bug.

Mhm, i am also using Debian. Debian/Sid precisely. I see this crash with my
today seamonkey, self compiled. The image is displayed, but after a short time
... boom.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051003 SeaMonkey/1.1a
Mnenhy/0.7.2.10011
(Reporter)

Comment 5

13 years ago
I can also reproduce the behaviour with this html-snippet:

<html><body><img src="http://www.bc2va.org/cgi-bin/text_counter_hack.xbm?gyach"
name="counter"></body></html>

(Thanks to Evgeni for finding this out)

Comment 6

13 years ago
Thank you Wolf ;-)

I just tested a bit around with this XBM file. (German post is on d-u-g)
This file tries to display an image, which is 1px high and 29226px broad. I
think this is too much for FF/some Debian lib.

--snip--
zhenech@hexenkessel:~$ head text_counter_hack.xbm\?gyach
#define count_width 29226
#define count_height 1
static char count_bits[] = {
0x00,
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
0x00, 0x00,
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
0x00, 0x00,
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
0x00, 0x00,
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
0x00, 0x00,
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
0x00, 0x00,
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
0x00, 0x00,

Updated

13 years ago
Assignee: nobody → blizzard
Component: General → GFX: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Version: unspecified → 1.7 Branch

Comment 7

13 years ago
Created attachment 199584 [details]
testcase: xbm

Comment 8

13 years ago
Created attachment 199585 [details]
testcase: gif

both the .xbm and .gif crash for me on unstable debian (xorg 6.8.2.dfsg.1-8)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Comment 9

13 years ago
Could be related to bug 153621, but that's pretty generic and the testcase (url)
is no longer valid. Opera 8.5 doesn't crash on either.

Comment 10

13 years ago
Is everyone experiencing the problem a debian user?

I'm not 100% sure that this is the same issue, but ...

http://lists.debian.org/debian-user/2005/11/threads.html#00138
  http://lists.debian.org/debian-user/2005/11/msg00138.html
  http://lists.debian.org/debian-user/2005/11/msg00272.html
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=335708
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=334654

http://www.movieweb.com/movies/trailers.php
http://www.movieweb.com/forums/viewtopic.php?t=6036&e=9797

The only way I'm able to load either in Firefox 1.5rc1 or 1.0.7 is by disabling images. So, I ran 'wget -EHkKp ...' on the trailers page and viewed every image individually, but no crash...

I found 3 on irc running ubuntu who were unable to reproduce. Maybe it's Debian's gtk2 or Xorg?

Comment 11

13 years ago
Mozilla (gtk1) crashes on me as well. If it was Xorg/xlibs, you'd think Opera would have problems with this also. Guess I'll have to give 312731#c20 a shot, sometime.

Comment 12

13 years ago
Is this the same as bug 314873?

I'm getting a crash in Firefox rc2 (I think - "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051107 Firefox/1.5") on a movieweb.com url - in particular it seems to be http://dvddungeon.com/media/build/main_header/bg2.gif which is 15000 by 78 pixels in side.  Loading this image on its own from the urlbar crashes firefox with the same error.  

I'm getting the  'BadAlloc (insufficient resources for operation)' error as
well with "error_code 11 request_code 53 minor_code 0".

I'm running Debian, libgtk seems to be version 2.6.10-1.

The macos x firefox rc2 does not crash on the same image.

Comment 13

13 years ago
Jeff, I'm not really sure. I don't crash on that page and the error I get is a bit different: "WARNING: NS_ENSURE_TRUE(shell) failed, file /moz/mozilla/content/base/src/nsImageLoadingContent.cpp, line 792".

Comment 14

13 years ago
both attachments and the URL from comment 12 workforme with linux seamonkey trunk 20051112 on FC4 (gtk 2.6.10 and 1.2.10)

Comment 15

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051113 Firefox/1.6a1

Works for me, too, with gtk 2.8.6 and 1.2.10 on Ubuntu 5.10. If anyone that's crashing wants to debug this, feel free to e-mail me on how to do so.

Comment 16

13 years ago
(In reply to comment #10)
> Is everyone experiencing the problem a debian user?

I'm a user, not a programmer.  The box is Debian sarge with all security updates.  The only non-debian program is firefox 1.5 RC3 installed locally from mozilla.org and auto updated.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Attempting to load http://www.movieweb.com crashes firefox every time.  I manually submitted TB12000308H this morning.  The site also crashed FF on earlier versions.

The xterm error reported was:
~$ The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 45110 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Loads fine with konqueror, though it throws many xterm screens full of errors (BadPixmap, BadAlloc).

Updated

13 years ago
Keywords: talkbackid

Comment 17

13 years ago
some crash/error with this image:

image: http://upload.wikimedia.org/wikipedia/de/2/2a/Oberes_Turmberg_Panorama.jpg

location: http://de.wikipedia.org/wiki/Bild:Oberes_Turmberg_Panorama.jpg

tested browser, all will crash:
Mozilla 1.7.11
Firefox 1.06
epiphany 1.8.0
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
(normal download version)

Linux: Slackware

Comment 18

13 years ago
Created attachment 204791 [details]
testcase: png

Comment 19

13 years ago
Has also appeared on 1.8 Mozilla Suite (latest nightly), Firefox 1.5, Deer Park Alpha2 (latest nightly). Got these error messages:

From mozilla:

Gdk-ERROR **: BadAlloc (insufficient resources for operation)
  serial 28503 error_code 11 request_code 53 minor_code 0
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 28504 error_code 9 request_code 147 minor_code 3

From Deer Park:

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 227599 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

This is reproducable with the above given test case. I have also included another test case which is a 15000x300 white png image.

Linux box was:

Linux deskpro12500 2.6.8-2-686 #1 Thu May 19 17:53:30 JST 2005 i686 GNU/Linux

Error is also reproducable on Epiphany 1.4.8, Firefox 1.0.7 & Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050927 Debian/1.7.8-1sarge3

Updated

13 years ago
Attachment #204791 - Attachment description: This is a 15000x300 px blank png which exhibits the same feature as other attached images → testcase: png

Comment 20

13 years ago

*** This bug has been marked as a duplicate of 210931 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 21

13 years ago
Mozilla/5.0 (X11; U; Linux x86_64; it-IT; rv:1.7.12) Gecko/20051010 Firefox/1.0.4 (Ubuntu package 1.0.7)

Hi, I cannot reproduce those bugs, but sometimes firefox hangs with:

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 24280075 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I still haven't understood when in crashes, but when it hangs, the window manager crashes too. Look at here for some details:

http://ubuntuforums.org/showthread.php?t=104553

I have this problem with Ubuntu/Breezy. With Hoary, everything was ok
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.