adding bookmarks for idn-domains dont use the favicon

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
14 years ago
2 years ago

People

(Reporter: cabotine, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(firefox30 affected, firefox31 affected, firefox32 affected, firefox33 affected, firefox-esr24 affected)

Details

()

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8b5) Gecko/20050922 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8b5) Gecko/20050922 Firefox/1.4

If i tried to add a bookmark (toolbar or bookmarks themselves) the favicon isnt
used for it.

Reproducible: Always

Steps to Reproduce:
1.Drag link to toolbar
2.Reclick link as i usually have to to activate favicon
3.nothing happens

Actual Results:  
nothing

Expected Results:  
show the favicon in the toolbar
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
still valid
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20081215 Minefield/3.2a1pre
Duplicate of this bug: 483411
OS: Windows XP → All
Confirmed on:
Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110705 Firefox/8.0a1

Bug for 6 years. Should we expect to correct it?
(In reply to comment #3)> Bug for 6 years. Should we expect to correct it?

no, you can submit a patch even now!
Sadly, I know nothing about this :(
Duplicate of this bug: 818471
This bug still exists since 2005.

https://währungsrechner.com and https://Конвертер-валют.com don't show favicon in bookmark.


This bug should be taken seriously and very important to fix. According to World IDN repoort 2014, 270 million domain names are IDNs.

More details on https://www.eurid.eu/files/publ/IDNWorldReport2014_Interactive.pdf
I'm not sure but this problem has been fixed already.
It is reproducible on nightly 2015-11-19 but not on 2015-11-20.
mozregression says
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8adfc688229848672e0ce4b996280770fef26d57&tochange=18b0d63d9f06d849a8358e5acff33f7fc70250f8
(maybe bug 412457)

(I'm getting this issue on 43.0 recently, but current nightly(46.0a1) does not have this issue anyway.)
Looks like fixed on Nightly.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.