Closed Bug 311060 Opened 14 years ago Closed 12 years ago

Extraneous empty tab rendered in preferences dialog when last tab selected

Categories

(Thunderbird :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 265698

People

(Reporter: kontakt, Assigned: mscott)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

There´s a bug in the config dialog with tabs. If I select the tab which is the
most right one, I always get another blank tab displayed next to it. When I
select another tab it disappears. I´m usng SuSE 10.1 alpha1, but since
Thunderbird renders its own widgets I don´t think this has something to do with it.

Reproducible: Always
worksforme.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051005
Thunderbird/1.4.1 ID:2005100506
I have actually started seeing this myself... I'm now on ubuntu 5.10. This could possibly be some kind of gnome bug. But is there anything we can do to fix it? The similar place in firefox does not have this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Do either of you guys see it in safe mode? WFM in version 1.6a1 (20051118) on Ubuntu 5.10 Linux.
Yep, can reproduce in safe-mode. Both latest trunk and branch builds. 

I noticed this can also be seen in other places (though not as clear), e.g. the folder properties dialog tabs. Looking closely, there also seems to be a very small extra tab in firefox Options | Privacy tabs.

Checked the program output and I'm seeing this whenever I open a view where the problem occurs:


(Gecko:8476): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion `gdk_window_is_viewable (src)' failed

(Gecko:8476): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion `pixbuf != NULL' failed

(Gecko:8476): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample: assertion `pixbuf != NULL' failed

(Gecko:8476): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `pixbuf != NULL' failed

(Gecko:8476): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `pixbuf != NULL' failed

(Gecko:8476): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion `pixbuf != NULL' failed

(Gecko:8476): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed


 
I can also see this problem with Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060611 Minefield/3.0a1. But the extra tab (in Preferences/Privacy) is very short. This is in a completely fresh profile of Firefox.
Is this resolved by bug 265698 ?
Summary: Tabs is config dialog rendered wrong → Extraneous empty tab rendered in preferences dialog when last tab selected
Yes, seems resolved by bug 265698. Marking as dupe.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265698
You need to log in before you can comment on or make changes to this bug.