Focus Grab problem: Moz-based Solaris webclient steals focus.

RESOLVED WORKSFORME

Status

defect
P3
major
RESOLVED WORKSFORME
20 years ago
8 years ago

People

(Reporter: edburns, Assigned: tim.miao)

Tracking

({access, helpwanted})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reproducible: ALWAYS

To reproduce:

1. Build and run webclient on Solaris.

2. Click in the URL text field and start typing, any text will do.

3. While typing, move the mouse into the web page area.

4. You'll find that the focus is stolen from the text field.  This is a major 
usability problem.
Just for kicks, adding the HELP_WANTED status word.
Whiteboard: HELP_WANTED
Added Geetha to CC list
Status: NEW → ASSIGNED
Keywords: helpwanted
Whiteboard: HELP_WANTED
I have a simpler wrapper that wraps IE and an url text field has the same
problem. I don't think this is limited to mozilla, but rather a JTextField focus
bug. 


The problem seem to be that even if the text field gets events, eg. a mouse
click to bring focus back to it, one has to select some other java component first.

Simply using a heavyweight TextField instead of a lightweight JTextField makes
the problem go away. 

I hope that the new focus manager in jdk1.4 will solve this problem.
In Webclient we are using a heavyweight AWT component TextField and not the 
Swing JTextField. We are seeing the problem because of the way Motif (peer 
components on Solaris for Java AWT) interacts with the Gtk components in 
Mozilla.
Changing QA contact
QA Contact: rajendra.pallath → avm
This bug still reproduced on Solaris 2.8 with nightly mozilla & webclient.
Add me to cc list.
Keywords: access
Depends on: atfmeta
No longer depends on: atfmeta
Blocks: atfmeta
Resummarizing, to more accurately dscribe problem
Summary: Focus Grab problem: Mozilla steals focus. → Focus Grab problem: Moz-based Solaris webclient steals focus.
Blocks: 140346
Ed, still a problem?
Assignee: ashuk → joe.chou
Status: ASSIGNED → NEW
QA Contact: avm → webshell-apis
Is this still a problem? If so, please reassign to someone on your team, otherwise mark it WORKSFORME.
Assignee: joe.chou → tim.miao
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.