Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/tabbro...

VERIFIED FIXED

Status

()

--
major
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Peter6, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

1.5.0.x Branch
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051005
Firefox/1.4.1 ID:2005100500

repro:
1. Open FF
2. open a number (3 or more) of tabs (blank tabs is ok)
3. close the last tab (!important) and 1 other tab
4. go to bookmarks and open a page in a new tab
5. drag the last tab you opened to any place on the tabbar
6. now drag that tab back to the last (right) position

result:
1. the tab does not move to the last position
2. the tab content reloads
3. there is no link from tabbar to tabs anymore
4. no other tabs can be selected
5. in JSC strict there sometimes is a warning:
Error: uncaught exception: 2147500037

6. keep JSC open while closing FF, JSC strict gives
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]" 
nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/bindings/tabbrowser.xml ::  :: line 2037"  data: no]
(Reporter)

Comment 1

13 years ago
related to Bug 311200 ?
(Reporter)

Comment 2

13 years ago
exception 2147500037 (acc
http://silver.warwickcompsoc.co.uk/mozilla/misc/nserror ) =
Code: 0x80004005 (2147500037, -2147467259)
Name: Failure (NS_ERROR_FAILURE)
Module: <unknown>
Serverity: Failure (1)
Number: 16389

Yes, this is related to bug 311200.
http://lxr.mozilla.org/seamonkey/source/toolkit/content/widgets/tabbox.xml#264
is where it's throwing.
Keywords: dataloss
OS: Windows 2000 → All
Hardware: PC → All
Peter, I assume this bug has been present since tab drag&drop landed (can't test
ATM)?
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> Peter, I assume this bug has been present since tab drag&drop landed (can't test
> ATM)?

Nope,
there is some weirdness going on which i need to properly investigate but this
bug definitly regressed between:

works in 20051003 2217pdt build
fails in 20051004 0252pdt build

and was not fixed by bug 311090 or Bug 310993


(Reporter)

Comment 6

13 years ago
Created attachment 198604 [details]
.swf for testcase

testcase + explanation follows
(Reporter)

Comment 7

13 years ago
Created attachment 198605 [details]
testcase

repro the problem in much earlier builds (fails in 20050901, haven't checked
before that date yet)

repro:
1.bookmark the testcase
2.follow steps of comment 0 and use the this testcase for step 4 !
(Reporter)

Comment 8

13 years ago
As said, this is somehow fishy.
I can sometimes repro the testcase with older builds and sometimes not (I used a
new created profile for every build)

It's probably best to ignore all ecept the regressionwindow 20051003/20051004
(In reply to comment #5)
> Nope,
> there is some weirdness going on which i need to properly investigate but this
> bug definitly regressed between:
> 
> works in 20051003 2217pdt build
> fails in 20051004 0252pdt build

Hmm, looking at
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=MOZILLA_1_8_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005+10+04+02%3A52&maxdate=2005+10+03+22%3A17&cvsroot=%2Fcvsroot
I see nothing that should have caused this.

I can definitely reproduce this on the branch, though. I just used a bug query
as the bookmark for step 4, the page that's loaded shouldn't matter.
(Reporter)

Updated

13 years ago
Depends on: 311136
No longer depends on: 311136
Fixed by checkin for bug 311295 (branch).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Depends on: 311295
Resolution: --- → FIXED
(Reporter)

Comment 11

13 years ago
*** Bug 312044 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
Verified fixed (actually, WFM) using Win FF 1.5.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

12 years ago
The original summary for this bug was longer than 255 characters, and so it was truncated when Bugzilla was upgraded. The original summary was:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebProgress.removeProgressListener]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/tabbrowser.xml ::  :: line 2037"  data: no]
You need to log in before you can comment on or make changes to this bug.