Last Comment Bug 311330 - ssl_help.xhtml contains outdated links to NSS documentation
: ssl_help.xhtml contains outdated links to NSS documentation
Status: RESOLVED FIXED
: fixed1.8
Product: SeaMonkey
Classification: Client Software
Component: Help Documentation (show other bugs)
: unspecified
: All All
: -- trivial (vote)
: ---
Assigned To: Giacomo Magnini
: Daniel Wang
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 03:42 PDT by Giacomo Magnini
Modified: 2005-12-22 16:35 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Update the link to the most recent version of the document (1.05 KB, patch)
2005-10-06 03:44 PDT, Giacomo Magnini
no flags Details | Diff | Splinter Review
Fix for a number of broken links and update Copyright years (12.33 KB, patch)
2005-10-26 07:50 PDT, Giacomo Magnini
iann_bugzilla: review-
Details | Diff | Splinter Review
Updated patch with fixes collected during IRC chats and more (35.56 KB, patch)
2005-12-09 01:30 PST, Giacomo Magnini
iann_bugzilla: review-
Details | Diff | Splinter Review
What Ian asked (checked in to trunk/branch 1.8 & 1.8.0). (15.16 KB, patch)
2005-12-11 01:23 PST, Giacomo Magnini
iann_bugzilla: review+
iann_bugzilla: approval‑seamonkey1.0+
Details | Diff | Splinter Review

Description Giacomo Magnini 2005-10-06 03:42:35 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

ssl_help.xhtml has a link to NSS documentation referring to version 3.4. In the
mean time, SM uses 3.10, but the same document referenced by the help file is
available only for version 3.9. Anyway, it is much better to update the link.
Patch coming up (2 liner).

Reproducible: Always

Steps to Reproduce:
Comment 1 Giacomo Magnini 2005-10-06 03:44:48 PDT
Created attachment 198680 [details] [diff] [review]
Update the link to the most recent version of the document
Comment 2 Giacomo Magnini 2005-10-06 10:13:13 PDT
Comment on attachment 198680 [details] [diff] [review]
Update the link to the most recent version of the document

More dead links, looking for alternatives...
Comment 3 Mark Banner (:standard8) 2005-10-06 11:09:14 PDT
Confirming on

Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8b4) Gecko/20050913 SeaMonkey/1.0a.

Comment 4 Ian Neal 2005-10-09 03:48:11 PDT
Might be worth updating copyright message too?
Comment 5 Giacomo Magnini 2005-10-09 06:05:10 PDT
(In reply to comment #4)
> Might be worth updating copyright message too?

Ok, but there are many more broken links in the docs: for a few ones, I've found
the equivalent pages on ns8 doc website, for the others, only archive.org links
are available and Neil doesn't like the idea.
I've asked dria if she can retrieve the pages trough RH (since they seem to be
gone there copyright wise after the server buy out), and she should have asked
blizzard about it. Waiting for the answer next week.
Comment 6 Giacomo Magnini 2005-10-26 07:50:56 PDT
Created attachment 200872 [details] [diff] [review]
Fix for a number of broken links and update Copyright years

Quick solution: update the links to existing pages (some on ns8 online docs, some on RH online manuals).
The long term solution will be to put the RH docs on DevMo and then link those, but it will take time (both documents are more than 100Kb). So this is a partial solution to get back some useful content from the inline help.
Comment 7 Ian Neal 2005-10-27 14:45:22 PDT
Comment on attachment 200872 [details] [diff] [review]
Fix for a number of broken links and update Copyright years

>Index: extensions/help/resources/locale/en-US/nav_help.xhtml
>===================================================================
.
.
> <p>If you are new to the Internet, see the
>-  <a href="http://home.netscape.com/bookmark/7_0/hnewbie.html">New to the Net
>+  <a href="http://wp.netscape.com/netcenter/newnet/index.html">New to the Net
>   Tutorial</a>.</p>
> 
Alot of the information at that link refers to Netscape Communicator 4.5, is there a better link?

>Index: extensions/help/resources/locale/en-US/privacy_help.xhtml
>===================================================================
.
.
> <p>For general information about privacy and security, including descriptions
>   of viruses, safe online shopping and banking, and safe surfing for children,
>   see the online document
>-  <a href="http://home.netscape.com/security/basics/index.html?cp=sciln">Understanding
>+  <a href="http://browser.netscape.com/ns8/security/basics_virus.jsp">Understanding
>   Security</a>.</p>
> 
This just seems to talk about viruses and not the more general side as it says in the text above, can you find a better link?
Comment 8 Giacomo Magnini 2005-10-28 07:10:34 PDT
(In reply to comment #7)
> Alot of the information at that link refers to Netscape Communicator 4.5, is
> there a better link?

Used that link to avoid a redirection, and the new one seems to be the most up to date information. Haven't found anything better, yet?

> This just seems to talk about viruses and not the more general side as it says
> in the text above, can you find a better link?

I had the same impression you had: but if you look on the menu *on the right* (not the most visible on the left) all of the previous content is present, though it's badly presented.
Comment 9 Giacomo Magnini 2005-10-28 07:17:13 PDT
What about this:
http://library.albany.edu/internet/
?
Comment 10 Giacomo Magnini 2005-10-28 07:25:13 PDT
This one is not bad, and more generic:
http://www.cs.indiana.edu/docproject/zen/zen-1.0_toc.html
This one has lots of infos, but the presntation is horrible:
http://www.ou.edu/research/electron/internet/

Pick one of your choice! ;)
Comment 11 Stefan [:stefanh] 2005-11-02 13:54:41 PST
 
> >Index: extensions/help/resources/locale/en-US/privacy_help.xhtml
> >===================================================================
> .
> .
> > <p>For general information about privacy and security, including descriptions
> >   of viruses, safe online shopping and banking, and safe surfing for children,
> >   see the online document


Hmm, we do talk about general stuff in the doc itself. So, I wonder if we need more general info.

There are several "new to the internet guides". The hard part is to pick a good one and make sure it's updated (and doesn't just talk about IE and NS). I think we want a "strict and nice one" if we really need one. So, some .gov/.edu is probably OK.

http://library.albany.edu/internet/ is OK, but it only mentions IE :(

http://www.lib.berkeley.edu/TeachingLib/Guides/Internet/WhatIs.html is OK, but just mentions IE and NS...

One question is how much we really need. I mean, isn't parts of http://wp.netscape.com/netcenter/newnet/index.html covered by the "Browsing the Web" section? We also have lots of explanations in the glossary (just look at "Internet" - ) ;)
 

Comment 12 Giacomo Magnini 2005-12-09 01:30:22 PST
Created attachment 205383 [details] [diff] [review]
Updated patch with fixes collected during IRC chats and more

This has been updated with IanN suggestions over IRC:
- splitted help links to ns8 docs about phishing, online banking, etc.
- use Internet Guide as a general introduction to the Web
- fix for Mozilla->&brandShortName; in help_help
- fix for minor nit in nav_help.xhtml

It includes the patch for bug 230355, which has sr=Neil, but needs another look by Ian.

This is good 1.0 material, since it will greatly reduce (or eliminate) broken content in the help files.
Comment 13 Ian Neal 2005-12-10 17:49:58 PST
Comment on attachment 205383 [details] [diff] [review]
Updated patch with fixes collected during IRC chats and more

Could you produce a diff that doesn't include the diff from the other patch you mentioned.
Comment 14 Giacomo Magnini 2005-12-11 01:23:49 PST
Created attachment 205535 [details] [diff] [review]
What Ian asked (checked in to trunk/branch 1.8 & 1.8.0).
Comment 15 Stefan [:stefanh] 2005-12-14 11:41:41 PST
Checked in (trunk/branch) by Standard8.
Comment 16 Ian Neal 2005-12-22 16:35:03 PST
Comment on attachment 205535 [details] [diff] [review]
What Ian asked (checked in to trunk/branch 1.8 & 1.8.0).

Checking in (branch 1.8.0)
certs_help.xhtml;
new revision: 1.45.16.1; previous revision: 1.45
help_help.xhtml;
new revision: 1.23.16.1; previous revision: 1.23
mail_sec_help.xhtml;
new revision: 1.30.16.1; previous revision: 1.30
nav_help.xhtml;
new revision: 1.53.8.2.4.1; previous revision: 1.53.8.2
passwords_help.xhtml;
new revision: 1.40.16.1; previous revision: 1.40
privacy_help.xhtml;
new revision: 1.42.14.1; previous revision: 1.42
ssl_help.xhtml;
new revision: 1.35.16.1; previous revision: 1.35
using_priv_help.xhtml;
new revision: 1.56.14.1; previous revision: 1.56
done

Note You need to log in before you can comment on or make changes to this bug.