Clicking on a window-decoration (resize, titlebar) causes animation to pause (freeze)

RESOLVED DUPLICATE of bug 241326

Status

()

--
trivial
RESOLVED DUPLICATE of bug 241326
13 years ago
5 years ago

People

(Reporter: wot.narg, Unassigned)

Tracking

({qawanted, regression})

1.5.0.x Branch
qawanted, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Clicking on the window-decorations in Windows XP causes animations to stop. So
far I've seen animated gifs and the loading spinny-thing (:p) both freeze.

This may be a Windows problem, as my linux partition isnt bootable atm, so I
can't test it there, or it may be a firefox problem.



Reproducible: Always

Steps to Reproduce:
1. Load a page of find an animated gif.
2. Go to the side of the window, and click on the blue decorations, and get a
resize arrow.
3. Click
4. Enjoy
Note: Doesnt work when maximized, as you can't get a resize mouse.
Actual Results:  
Animations freeze.

Expected Results:  
Animations not freezing?

Default theme, windows XP with default theme, doesnt work maximized.

Comment 1

13 years ago
Cannot reproduce with
http://www.mrtech.com/animated/graphics/title.gif
http://www.snowcrest.net/kitty/hpages/hpic/nturs.gif

on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1 (same build) with a resized window both using Luna or not using
Luna on the default Firefox theme.

Comment 2

13 years ago
You won't notice by simply clicking, but if you hold the mouse button down on
the titlebar or window border then the animations will freeze until you release
the button. I've seen this in other Windows programs (nothing specific comes to
mind), however IE and Opera don't seem to do it.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051008
Firefox/1.4.1 ID:2005100821

Yes, I see this too.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Clicking on a window-decoration freezing all animations in firefox. → Clicking on a window-decoration (resize, titlebar) causes animation to pause (freeze)
Version: unspecified → 1.5 Branch

Comment 4

13 years ago
How does this behave on other OSes?
Keywords: qawanted
Whiteboard: DUPEME

Updated

13 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 5

13 years ago
Ria, do you think you could find out when this regressed? My friend claimed that this worked for him, and then I realized he was using 1.0.7.
Keywords: regression
I also see it in an old build from Feb 2004.
When I go to this site http://www.vwkweb.nl/index.html?http://www.vwkweb.nl/link/allesopeenrij.html , place the cursor on the titlebar and drag the window, all animations stop. 
The same happens while resizing the window.

Comment 7

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

The same thing.

Comment 8

11 years ago
Downloads are also paused by click-hold anywhere on the title bar of any <window> bug 398182

Comment 9

11 years ago
appears to be a dupe of bug 241326

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 241326

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.