Status

Mozilla Localizations
Registration & Management
VERIFIED FIXED
13 years ago
8 years ago

People

(Reporter: Anna Kristín Gunnarsdóttir, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; eu-ES; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; eu-ES; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

I would like to localize Firefox in Icelandic (is-IS). There is no localization
team registered at the moment.
Anna Kristín Gunnarsdóttir, anstin@yahoo.com. I'll be able to publish work on
the site www.7.is.


Reproducible: Always
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Anna, you should file another bug for a localization CVS account for you and attach your SSH public key to that bug. See bug 276067 for an example of the CVS account registration process.

In your CVS account request bug you should provide us with a ZIP or tar archive of your translation.

If there are other people who co-operate with you on the Icelandic localization,  they should be listed here as peers (and, if necessary, also get their own CVS accounts).

Also, you may consider using simply the "is" code for Icelandic, since (as far as I know) there are no variations of the Icelandic language spoken outside Iceland (which would justify the "-IS" part).
See http://wiki.mozilla.org/L10n:Simple_locale_names for more information.

If you have any questions, feel free to join the #l10n channel on irc.mozilla.org.
Hi!

My name is Gretar Orri Kristinsson and I'm very interested in helping to localize Firefox into Icelandic (is, is-IS). I have an experience in translating other software to Icelandic such as Skype, SAM (Answering Machine for Skype), Pamela (Assistant for Skype) and the NSIS installer.

Please contact me through firefox@gretar-orri.com

Best regards,
Gretar Orri Kristinsson
firefox@gretar-orri.com
http://skype.gretar-orri.com/
Gretar, Anna - are you willing to co-operate on this? It's much better for a localization team to consist of more than one person.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Gretar, Anna - are you willing to co-operate on this? It's much better for a
> localization team to consist of more than one person.
> 

There is already a team working on the translation. Gretar, you are welcome to join the team, we will contact you in the next few days.
(In reply to comment #4)
> (In reply to comment #3)
> > Gretar, Anna - are you willing to co-operate on this? It's much better for a
> > localization team to consist of more than one person.
> > 
> 
> There is already a team working on the translation. Gretar, you are welcome to
> join the team, we will contact you in the next few days.
> 

Hi Anna!  I obviously missed your reply... I would be happy to join the team.  If you already tried to contact me through firefox@gretar-orri.com, it seems that it didn't go through.  Please let me know how I can help!

/Grétar.
Summary: Localization of Firefox in Icelandic → [is-IS] Icelandic: Firefox
The short language code should be just 'is'.
Summary: [is-IS] Icelandic: Firefox → [is] Icelandic: Firefox
On behalf of the Mozilla Project, I'd like to apologise for the delay in processing this request. We very much appreciate offers of help in localization.

If anyone reading this is still interested in helping to translate one or more Mozilla products into the language that this bug is about, please add a new comment to this bug to confirm your interest, saying again which products you would like to localize e.g., Firefox, Thunderbird. We will then make the necessary arrangements.
(Reporter)

Comment 8

11 years ago
I'm still interested, but haven't had time to look into it lately. Next week I'm hoping to be able to start, though. I was thinking about Firefox to begin with, but if it goes well, I'd be willing to localize other products as well.
Great :-) When you are ready, you need to read this wiki page:
http://wiki.mozilla.org/L10n:Starting_a_localization

Create yourself a wiki page for your localisation, and then follow the instructions to produce a language pack you can distribute through addons.mozilla.org. Once you have reached that stage, we can consider your pack for official status - although I should warn you that this is a separate process with its own complexities. Still, the community will still be able to get your pack from addons.mozilla.org in the meantime.

If you have read carefully and find the documentation isn't good enough in any way, please let us know and we will improve it.

Gerv

Comment 10

11 years ago
On a not-so-related note, I recall there was something about download costs being significantly different for connections within Iceland and not. Is that still something to think about or has that been run over by broadband and flatrates alltogether? Or am I completely off anyways?
Anna: how are things going? Have you managed to make any progress?

Gerv
(Reporter)

Comment 12

11 years ago
No, I haven't. The people who originally seemed to be interested in working with me on the project haven't contacted me and my time to work on it is very limited. Most of all, though, I am put off by lack of technical expertise.
I hope someone out there sees this and steps up. We really need more Icelandic language software, people!

Anna
Anna: perhaps you would be able to perform a valuable service for us and the localisation community, then. 

We cannot help you with the lack of time and Icelandic-speakers. However, there should be no need for anyone to be put off localising Firefox by a lack of technical expertise. If that is the case, then our documentation and processes need improving. We aim to make the process accessible even to those who are not programmers (although a certain level of general computer literacy might be required).

So, if you were to work through the process of getting into a position to start your translation, carefully documenting what documents you read, where you went, what assumptions you made that turned out to be false, what roadblocks you ran into and so on, then even if you never got further than translating a single line into Icelandic, you would have given us valuable information to make the process less daunting for localisers into other languages (including, perhaps, a future Icelandic team to come).

For example, if you were to say "I read document X. Following its instructions, I tried to download software Y. But Y wouldn't run on my machine. After half an hour of searching, I found the solution buried in document Z." then we could, at minimum, fix document X to tell of the solution from document Z. And so on.

Are you interested in trying something like this?

Gerv
Hi.

My name is Kristján Bjarni Guðmundsson and I have just finished translating Firefox 2 and Firefox 3 beta to Icelandic, the translation homepage and the language pack are located here:
http://firefoxis.mozdev.org

I have also translated Sunbird to Icelandic:
http://icelandicsunbird.mozdev.org
and I am in the process of translating Thunderbird.

I am interrested in having the translations for Firefox to be part of the official release. What should I do next?
I have created a team page:

http://wiki.mozilla.org/L10n:Teams:is

I have read the Becoming an Official Localization:
http://wiki.mozilla.org/L10n:Becoming_an_Official_Localization

If I understand it correctly I should I just attach my localization sources to this current bug document?

Comment 16

10 years ago
Exactly. http://pagesperso-orange.fr/cedric.corazza.net/html/langpack2cvstree.html should be able to help you to convert your files to the source structure, there is more to do after that, though.

I suggest that you run compare-locales locally to figure out what and catch errors, there's more documentation on that on http://developer.mozilla.org/en/docs/Compare-locales

I skimmed briefly at the language pack, the is-IS.jar is OK, apart from the language code and some changes that are post B5, I guess. You have some fancy startup code in there, which we wouldn't take on AMO, though, just for reference.
I am running Windows so I can't use the langpack2cvstree script. Is there any other platform independent script that can do this or maybe some documentation on how I would convert the language pack to the source structure? If I can just get the English equivalent source tree for the browser, mail and calendar I am sure I could figure out the rest.

Yes I will change the language code to use "is" instead of "is-IS".

I added some startup code in the language pack to change the general.useragent.locale to is-IS if needed, because I don't find it very user friendly for the end users having to muck about with starting Firefox from the command line or using the config editor. But I don't mind removing that stuff for the official pack, since it isn't needed anyway.

Comment 18

10 years ago
There is good news and bad news. We don't have a toolchain for windows, we use the unix-like tools and run them in msys. Now, the good news is, it's really just one install you need, called MozillaBuild. See http://developer.mozilla.org/en/docs/L10n_Prerequisites and http://wiki.mozilla.org/MozillaBuild for that.

Once you have that, you'll be able to run Cedric's tool, and get the source.

http://developer.mozilla.org/en/docs/Creating_en-X-dude has instructions on how to get the en-US sources, just skip "Create a dummy localization". You don't need a dummy localization, you got one.

I just updated http://developer.mozilla.org/en/docs/Compare-locales#Installation to include some tweaks needed for MozillaBuild.

You can get more help on the #l10n irc channel on irc.mozilla.org, or in the newsgroup, http://www.mozilla.org/community/developer-forums.html#dev-l10n.
Created attachment 321931 [details]
Icelandic for Browser/Toolkit
Created attachment 321932 [details]
Icelandic for Calendar
OK I installed MozillaBuild, ran Cedric's tool and got the source directory from that for both Firefox and Calendar. I then translated all the new strings that where added. I have included the Firefox source files and the Calendar source for the Icelandic language as attachment to this bug.

Comment 22

10 years ago
Comment on attachment 321931 [details]
Icelandic for Browser/Toolkit

Nice to hear that that worked :-)

Mind setting the review flag on this attachment to '?' and enter my bugmail as requestee? That way it'll end up in queue.
Attachment #321931 - Flags: review?(l10n)
Attachment #321932 - Flags: review?(l10n)
Ok I set the review flag. It would be great if the Icelandic language could be included in time for the Firefox 3 release, do you think that could happen?

I was also thinking, the Firefox 3 is based on the branch 1.9, and so I have included the 1.9 branch for the toolkit/browser, but Calendar/Sunbird is based on branch 1.8, so I would think that I would have to include the toolkit also as branch 1.8 for the Calendar?
Created attachment 323551 [details]
Icelandic for Toolkit (Branch 1.8)

Icelandic for toolkit based on branch 1.8
Attachment #323551 - Flags: review?(l10n)
I was wondering about the status of the review?

Comment 26

10 years ago
Comment on attachment 321931 [details]
Icelandic for Browser/Toolkit

A bunch of simpler fixes, please:

really easy, browser/defines.inc should be in utf-8, you're seems to be windows-1252.

And all the ini files seem to have their keys turned into all lowercase, in

browser/crashreporter/crashreporter-override.ini
browser/updater/updater.ini
        +Info
        +Title
        -info
        -title
toolkit/crashreporter/crashreporter.ini

One of them with the problem left in.

The xml files in browser/searchplugins can be removed, they're picked up from en-US at build time, the only file you need right now is list.txt.

In bookmarks.html please replace the 'en-US' in the links with 'is', twice for each link.

The rest is looking pretty good. I'll defer the review of the other files, those likely have the same problems with the ini files.

Looking forward to a new package.
Attachment #321931 - Flags: review?(l10n) → review-

Comment 27

10 years ago
Comment on attachment 321932 [details]
Icelandic for Calendar

Same problem with ini files for this one.
Attachment #321932 - Flags: review?(l10n) → review-

Updated

10 years ago
Attachment #323551 - Flags: review?(l10n)
Created attachment 327383 [details]
Icelandic for Firefox 3 (Browser,Toolkit)
Attachment #321931 - Attachment is obsolete: true
Attachment #327383 - Flags: review?(l10n)
Created attachment 327385 [details]
Icelandic for Sunbird 0.9 (Calendar,Toolkit) (Branch 1.8)
Attachment #321932 - Attachment is obsolete: true
Attachment #323551 - Attachment is obsolete: true
Attachment #327385 - Flags: review?(l10n)
Thanks for the review.

I have fixed all these issues. I am attaching the new files.

Comment 31

10 years ago
Comment on attachment 327383 [details]
Icelandic for Firefox 3 (Browser,Toolkit)

r=me with nits on the ini files again. I'll be fixing those locally, though. It seems that our parsers for ini files don't drop whitespace around the =, so that needed to be removed.
Attachment #327383 - Flags: review?(l10n) → review+

Comment 32

10 years ago
Great, thanks, registration done.

I'll be filing a bug of bugs to track shipping Firefox 3 now, starting with the tracker bug 442899.

Mind filing a cvs account bug? It should depend on this bug, you find more details on that on http://wiki.mozilla.org/L10n:Becoming_an_Official_Localization#CVS_write_access.

Simon, do you want to take over the review of the calendar localization? You probably see the same ini file issues.

Marking this bug fixed just to indicate that we're good to go here in general.
Blocks: 442899
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Comment on attachment 327385 [details]
Icelandic for Sunbird 0.9 (Calendar,Toolkit) (Branch 1.8)

I just looked through most of the files and it looks fine. A few issues remain:
- You know of the remaining ini issues (whitespaces) from Axel already
- I noticed that a lot of files had DOS line endings instead of UNIX line endings. I counted more than 30 files. Please correct those.

There will probably be some other mistakes (e.g. missing strings) but those can be corrected after the initial checkin
Attachment #327385 - Flags: review?(l10n) → review?(bugzilla)

Updated

10 years ago
Attachment #327385 - Flags: review?(bugzilla) → review+
Axel, when you land the initial strings for Firefox. Could you perhaps land the Calendar and toolkit strings on the 1.8 branch as well.

My commit rights currently apply only for calendar-related strings and I don't want to step into other territory here.

Comment 35

10 years ago
Nice catch, I'll fix the line endings in a follow up check-in. Simon, do you have a tool thing that warns you on that, or do you just massively run 'file' on stuff?

Kristjan, please make sure that you're continuing your work on a pristine check-out, so that we keep those fixes going forward.

Regarding the calendar landing, I'd like to focus on the fx3 locales for now, that's tough enough. File a bug on that with checkin-needed keyword and the full instructions? Because this is likely multibranch foo, too?
(In reply to comment #35)
> Nice catch, I'll fix the line endings in a follow up check-in. Simon, do you
> have a tool thing that warns you on that, or do you just massively run 'file'
> on stuff?

My Windows text-editor "Ultraedit" shows the line endings (DOS/UNIX/MAC) for every file. So if you open a number of files, you can easily scan through those quickly.

> Regarding the calendar landing, I'd like to focus on the fx3 locales for now,
> that's tough enough. File a bug on that with checkin-needed keyword and the
> full instructions? Because this is likely multibranch foo, too?

As far as I can see, this would only be for the 1.8 branch for now. I can do the corresponding checkin for the cvs trunk.
Blocks: 442963
I was wondering about the status of the checkin of 1.8 branch for Sunbird? 
I'll poke Pike about this here on the Mozilla summit.
I just landed the is calendar localization on both trunk and 1.8 branch. I've also added the localization to all-locales, so that our tinderboxen can start building Islandic localized builds.

Please use compare-locales to find (and then fix) the remaining errors in the localization. Thanks.
Status: RESOLVED → VERIFIED
It seems that some files on the is 1.8 branch are from the Firefox 3 toolkit. For example the files in "l10n/is/toolkit/chrome/mozapps/handling/". I would have thought that this would be incorrect for the 1.8 branch or am I misunderstanding something?
No, you aren't. What I did was to branch the current trunk toolkit strings. I just haven't gotten to correcting the remaining issues. I hope to do it tonight or early next week.
I removed the unused files from the trunk. Everything should be fine now. At least I see no errors in compare-locales
I would now like to localize Thunderbird into Icelandic. Should I translate it offline and add the attachment here to start the localization or since I already have access to Mercurial http://hg.mozilla.org/l10n-central/is should I just add the translated strings there directly?
Kristján, just add the translated strings directly in the mail directory of your "is" repository on l10n-central.

Once you think the translation is ready and a local compare-locales run tells you this as well, file a new bug on me to get localized Thunderbird builds.
You need to log in before you can comment on or make changes to this bug.