Oracle Jinitiator Plugin no longer loads

RESOLVED FIXED in mozilla1.9alpha1

Status

()

P1
blocker
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: iann_bugzilla, Assigned: Biesinger)

Tracking

({ecommerce, regression})

Trunk
mozilla1.9alpha1
ecommerce, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
For builds from BuildID 2005092205 onwards the Oracle Jinitiator plugin no
longer loads meaning that mozilla web browsers built from trees after that date
cannot be used to access Oracle web-enabled applications.

I suspect that it was the checkin for bug 1156 that broke this.
(Reporter)

Comment 1

13 years ago
Created attachment 199068 [details]
Example Oracle page that is supposed to load plugin

This html is generated by the oracle system and should then cause the Oracle
Jinitiator plugin to load up.
gah, an <embed> with no src attribute... copying from DOMI:

<EMBED width="558" height="120" orbdisablelocator="true"
       boxprogresscolor="0,255,0" boxfgcolor="black" boxbgcolor="gray"
       boxmessage="Downloading Oracle Applications 11i jar files..."
       progressbar="true" image="" cursorblinkrate="600" nlslang="true"
heartbeat="2"
       imagebase="CodeBase" donttruncatetabs="true" background="no"
       readonlybackground="automatic" darklook="true"
       splashscreen="oracle/apps/media/splash.gif" lookandfeel="oracle"
       colorscheme="blue"
       serveruserparams="NLS_LANG='AMERICAN_AMERICA.US7ASCII'
FORMS60_USER_DATE_FORMAT='DD-MON-RRRR' FORMS60_USER_DATETIME_FORMAT='DD-MON-RRRR
HH24:MI:SS' NLS_DATE_LANGUAGE='AMERICAN'"
      
serverargs="module=/app/jepfinl/app11i/jepfinlappl/fnd/11.5.0/forms/US/FNDSCSGN
userid=APPLSYSPUB/PUB@JEPFINL fndnam=APPS  config='hou1_jepfinl'
icx_ticket='.421287765' resp='SQLGL/JHA_GL_ENQUIRY' secgrp='STANDARD' "
       registrypath="/OA_JAVA/oracle/apps/fnd/formsClient"
       serverapp="OracleApplications" networkretries="0" connectmode="socket"
       serverport="9005" serverhost="hou3.jephson.org" serverurl=""
       separateframe="true"
      
archive="/OA_JAVA/oracle/apps/fnd/jar/fndforms.jar,/OA_JAVA/oracle/apps/fnd/jar/fndformsi18n.jar,/OA_JAVA/oracle/apps/fnd/jar/fndewt.jar,/OA_JAVA/oracle/apps/fnd/jar/fndswing.jar,/OA_JAVA/oracle/apps/fnd/jar/fndbalishare.jar,/OA_JAVA/oracle/apps/fnd/jar/fndaol.jar,/OA_JAVA/oracle/apps/fnd/jar/fndctx.jar,/OA_JAVA/oracle/apps/fnd/jar/fndlist.jar"
       code="oracle.forms.engine.Main" codebase="/OA_JAVA/"
       pluginurl="http://www.javasoft.com/" legacy_lifecycle="false"
type="application/x-java-applet;jpi-version=1.4.1"/>
Created attachment 199080 [details] [diff] [review]
patch

Can you test this patch?
Assignee: nobody → cbiesinger
Status: NEW → ASSIGNED
Blocks: 1156
Priority: -- → P1
Target Milestone: --- → mozilla1.9alpha
(Reporter)

Comment 4

13 years ago
Comment on attachment 199080 [details] [diff] [review]
patch

Yeah tested and Jinitiator now works again, thanks :-)
Attachment #199080 - Flags: superreview?(bzbarsky)
Attachment #199080 - Flags: review?(bzbarsky)
Comment on attachment 199080 [details] [diff] [review]
patch

r+sr=bzbarsky, and let's hope people don't do this with <applet>.  ;)
Attachment #199080 - Flags: superreview?(bzbarsky)
Attachment #199080 - Flags: superreview+
Attachment #199080 - Flags: review?(bzbarsky)
Attachment #199080 - Flags: review+
yeah... i think for <applet> it's really unlikely that people would do it.

fixed on trunk
Checking in content/html/content/src/nsHTMLSharedElement.cpp;
/cvsroot/mozilla/content/html/content/src/nsHTMLSharedElement.cpp,v  <-- 
nsHTMLSharedElement.cpp
new revision: 1.55; previous revision: 1.54
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
*** Bug 312256 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
*** Bug 329010 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
(In reply to comment #8)
> *** Bug 329010 has been marked as a duplicate of this bug. ***
> 

Can anyone tell me how to apply the patch provided by Christian?
You need to log in before you can comment on or make changes to this bug.