Last Comment Bug 312097 - [FIX]Pages with frames and JS alert fail to render FF 1.5b2
: [FIX]Pages with frames and JS alert fail to render FF 1.5b2
Status: RESOLVED FIXED
: fixed1.8, regression, testcase
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: P1 normal with 1 vote (vote)
: mozilla1.8rc1
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
: Hixie (not reading bugmail)
:
Mentors:
http://toastytech.com/data/frames.html
Depends on: 312942
Blocks: 253951 311785
  Show dependency treegraph
 
Reported: 2005-10-11 14:23 PDT by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2011-08-05 21:31 PDT (History)
7 users (show)
asa: blocking1.8rc1+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (1.71 KB, patch)
2005-10-11 15:58 PDT, Boris Zbarsky [:bz] (still a bit busy)
jonas: review+
jst: superreview+
asa: approval1.8rc1+
Details | Diff | Splinter Review
Testcase (644 bytes, text/html)
2006-04-03 10:09 PDT, Boris Zbarsky [:bz] (still a bit busy)
no flags Details

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2005-10-11 14:23:23 PDT
This came from:
http://forums.mozillazine.org/viewtopic.php?t=328434&highlight=

The url testcase fails to render in current trunk builds and in Firefox1.5beta2

This used to work in the 2005-08-24 build, but doesn't work in the 2005-08-25 build:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-08-24+12%3A00%3A00&maxdate=2005-08-25+09%3A00%3A00&cvsroot=%2Fcvsroot

Maybe because of bug 253951?
Comment 1 Peter van der Woude [:Peter6] 2005-10-11 15:48:13 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051011
Firefox/1.4.1 ID:2005101113

Same for Branch
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2005-10-11 15:58:32 PDT
Created attachment 199224 [details] [diff] [review]
Fix
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2005-10-11 15:59:52 PDT
Comment on attachment 199224 [details] [diff] [review]
Fix

This is just a copy of what we do for <body>.  The real issue is that OpenHTML
and CloseHTML do nothing of the sort, so we never actually notify on the kids
of <html> through the normal codepath!	This used to work, sorta, because
StartLayout() didn't happen till we hit CloseFrameset(), but that's no longer
true.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2005-10-11 17:32:34 PDT
Requesting blocking; I think it's worth getting this regression fixed...
Comment 5 Johnny Stenback (:jst, jst@mozilla.com) 2005-10-13 17:29:18 PDT
Comment on attachment 199224 [details] [diff] [review]
Fix

sr=jst
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2005-10-14 15:47:33 PDT
Fixed on trunk.
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2005-10-14 15:48:55 PDT
To expand on that approval request, this should be fairly safe -- we've been
using this exact code for <body> for ages, and the only reason we didn't use it
for <frameset> was because it wasn't strictly necessary.  Now it is.
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2005-10-16 19:56:16 PDT
Fixed on branch.
Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2006-04-03 10:09:16 PDT
Created attachment 217036 [details]
Testcase
Comment 10 Boris Zbarsky [:bz] (still a bit busy) 2006-04-03 10:18:52 PDT
It looks like on trunk this got busted by the checkin for bug 311785; I'll try to refix it in bug 315369, probably.

Note You need to log in before you can comment on or make changes to this bug.