SVG "em" notation in the <tspan> "dy" attribute is not being correctly implemented

VERIFIED DUPLICATE of bug 305859

Status

()

defect
VERIFIED DUPLICATE of bug 305859
14 years ago
14 years ago

People

(Reporter: johannes.wierny, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

It seems the "em" notation in the <tspan> "dy" attribute is not being correctly
implemented. Using the same code with absolute values i.e. dy="10pt" the SVG is
correctly displayed. The same graphic using "em" is also correctly displayed in ASV.

Reproducible: Always

Steps to Reproduce:
Use the following SVG code:

*****
<?xml version="1.0" encoding="UTF-8"?>
<svg xmlns="http://www.w3.org/2000/svg"
xmlns:xlink="http://www.w3.org/1999/xlink" contentStyleType="text/css"
height="100%" version="1.0" viewBox="0 0 1190.55 841.89" width="100%">
	<style type="text/css">
	<![CDATA[
		.style1
{fill:#ffffff;stroke:#000000;stroke-linecap:round;stroke-linejoin:round;stroke-width:0.72}
		.style2 {fill:#000000;font-family:Arial;font-size:12pt;font-weight:bold}
	]]>
	</style>

	<g>
		<g id="rect1">
			<rect x="0" y="1.44" width="187.087" height="29.7638" class="style1"/>
			<text x="28.53" y="12.72" class="style2">Text1 Text2 Text3<tspan x="66.22"
dy="1.2em">Test 4</tspan></text>
		</g>
	</g>
</svg>
*****
The code above will show the incorrect implementation.

Actual Results:  
The first text line is superimposed by the second text line. 

Expected Results:  
The second text line should be displayed below the first text line.

Comment 1

14 years ago
*** Bug 312167 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
*** Bug 312170 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
*** Bug 312172 has been marked as a duplicate of this bug. ***
*** Bug 312140 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
This breaks a lot a existing valid content, and should be fixed for the release
of FF1.5 if possible.

*** This bug has been marked as a duplicate of 305859 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.