crash scrolling mousewheel outside app boundaries

VERIFIED DUPLICATE of bug 32232

Status

()

Core
Event Handling
P3
critical
VERIFIED DUPLICATE of bug 32232
19 years ago
16 years ago

People

(Reporter: Mike Jaques, Assigned: joki (gone))

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Mozilla crashes when you load http://bugzilla.mozilla.org/query.cgi then scroll 
outside the applications boundaries while the query form has focus.

Reproducible: Always
Steps to Reproduce:
1.Open mozilla.exe
2.load: http://bugzilla.mozilla.org/query.cgi
3.Scroll on bugzilla page to make sure focus active
4.Move cursor outside the application boundaries with application still
  as "top" focus'ed window, and continue scrolling, rapidly.

Actual Results:  Crash.

Expected Results:   No crash, application mimics IE and stop scroll. (I dont 
know how NS 4.7x responses, havent used it for a long time.)

Build Date & Platform: occurs on seamonkey (03/09 build on Win98)

Three Stack Dumps:

MOZILLA caused an invalid page fault in
module <unknown> at 0000:4306f626.
Registers:
EAX=0044baec CS=015f EIP=4306f626 EFLGS=00010202
EBX=0000020a SS=0167 ESP=0068fa98 EBP=0068fb38
ECX=0044baec DS=0167 ESI=0126c980 FS=198f
EDX=0000f700 ES=0167 EDI=00000001 GS=0000
Bytes at CS:EIP:

Stack dump:
60a86ea6 0000020a ff880000 012703e9 0068fb7c 0068fb70 0126c980 012703e9 
ff880000 012703e9 00000000 c3300000 00040000 16df2d8c 00000001 bff741fb 

MOZILLA caused an invalid page fault in
module <unknown> at 0000:4306f626.
Registers:
EAX=0044baec CS=015f EIP=4306f626 EFLGS=00010202
EBX=0000020a SS=0167 ESP=0068fa98 EBP=0068fb38
ECX=0044baec DS=0167 ESI=0127a4f0 FS=5e3f
EDX=0000f700 ES=0167 EDI=00000001 GS=0000
Bytes at CS:EIP:

Stack dump:
60a86ea6 0000020a ff880000 013603e7 0068fb7c 0068fb70 0127a4f0 013603e7 
ff880000 013603e7 00000000 c3300000 00040000 16df2d8c 00000001 bff741fb 

MOZILLA caused an invalid page fault in
module GKWIDGET.DLL at 015f:60a86e98.
Registers:
EAX=08434218 CS=015f EIP=60a86e98 EFLGS=00010206
EBX=0000020a SS=0167 ESP=0068faa8 EBP=0068fb38
ECX=00000010 DS=0167 ESI=016d5ac0 FS=5a4f
EDX=60a86e91 ES=0167 EDI=00000001 GS=0000
Bytes at CS:EIP:
8b 10 8b c8 ff 75 10 ff 75 0c 53 ff 52 14 e9 ab 
Stack dump:
0068fb7c 0068fb70 016d5ac0 020f03e8 00780000 020f03e8 00000000 c4540000 
00040000 16df2d8c 00000001 bff741fb 04420879 16bf17af 00008b10 5ac00038
(Reporter)

Comment 1

19 years ago
Created attachment 6341 [details]
mozilla stack dumps ala text file
(Reporter)

Comment 2

19 years ago
Created attachment 6342 [details]
mozilla stack dumps ala text file
(Reporter)

Comment 3

19 years ago
seems to work for me now on the 4:15pm  3/9/00 nightly .... must have been 
something with the horkage of this morning ....... I'll check it again in a day 
or two to make sure
(Reporter)

Comment 4

19 years ago
Its back, same steps to reproduce in 2000031008 build at page: 
http://www.mozilla.org/mozorg.html

MOZILLA caused an invalid page fault in
module GKWIDGET.DLL at 015f:60a86e98.
Registers:
EAX=029cdd20 CS=015f EIP=60a86e98 EFLGS=00010202
EBX=0000020a SS=0167 ESP=0068faa8 EBP=0068fb38
ECX=00000010 DS=0167 ESI=01845600 FS=2aaf
EDX=60a86e91 ES=0167 EDI=00000001 GS=0000
Bytes at CS:EIP:
8b 10 8b c8 ff 75 10 ff 75 0c 53 ff 52 14 e9 ab 
Stack dump:
0068fb7c 0068fb70 01845600 00e503cf 00780000 00e503cf 00000000 c35f0000 
00040000 16df2d8c 00000001 bff741fb 04422d59 16bf17af 00008b10 56000038 6df2d8c 
00000001 bff741fb 04420879 16bf17af 00008b10 5ac00038 

MOZILLA caused an invalid page fault in
module GKWIDGET.DLL at 015f:60a86e98.
Registers:
EAX=029cdd20 CS=015f EIP=60a86e98 EFLGS=00010202
EBX=0000020a SS=0167 ESP=0068faa8 EBP=0068fb38
ECX=00000010 DS=0167 ESI=01662300 FS=3d8f
EDX=60a86e91 ES=0167 EDI=00000001 GS=0000
Bytes at CS:EIP:
8b 10 8b c8 ff 75 10 ff 75 0c 53 ff 52 14 e9 ab 
Stack dump:
0068fb7c 0068fb70 01662300 012f0312 00780000 012f0312 00000000 c35f0000 
00040000 16df2d8c 00000001 bff741fb 04422d59 16bf17af 00008b10 23000038 
(Reporter)

Comment 5

19 years ago
Still happening on 2000032108 (3/21 am daily build).  Am I the only one seeing 
this?!?   All you have to do is have a page scrollable, fiddle/scroll around in 
it,   move the cursor outside the application, say just off to the side, and 
start scrolling again and CRASH!    Adding keyword crash so maybe it will show 
up on someone's rador and get some more attention.  Otherwise, scrolling is 
much smoother then it used to be. Kudo's on that .. if this is not just a 
condition of my system (win98, intellipoint 3 drivers, ie5 downgraded ;-) it 
would seem to be some sort of constraint error where the browser still tries to 
handle scroll requests when it shouldnt, cant assign it to a window, and poops 
out. *shrug*  I don't know anything for sure though.

MOZILLA caused an invalid page fault in
module GKWIDGET.DLL at 015f:60a96ec2.
Registers:
EAX=027c44bc CS=015f EIP=60a96ec2 EFLGS=00010202
EBX=0000020a SS=0167 ESP=0068faac EBP=0068fb3c
ECX=00000010 DS=0167 ESI=016911f0 FS=7517
EDX=60a96ebb ES=0167 EDI=00000001 GS=0000
Bytes at CS:EIP:
8b 10 8b c8 ff 75 10 ff 75 0c 53 ff 52 14 e9 59 
Stack dump:
0068fb80 0068fb74 016911f0 01cf0393 fda80000 01cf0393 00000000 c3720000 
00040000 16df2d8c 00000001 bff741fb 04426769 16bf17af 00008b14 11f00038 
Keywords: crash
Target Milestone: --- → M15

Comment 6

19 years ago
Probably a dupe, reporter will verify tomorrow if the fix for 32232 fixes this 
as well.

Comment 7

19 years ago
This was indeed a dup of 32232, and is now fixed.


*** This bug has been marked as a duplicate of 32232 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
verified duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.