Last Comment Bug 312190 - Opening a saved email with an inline image does not display image
: Opening a saved email with an inline image does not display image
Status: RESOLVED DUPLICATE of bug 174692
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: ---
Assigned To: Scott MacGregor
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-12 09:02 PDT by sbrooks
Modified: 2005-10-12 12:33 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
sample message (1.97 KB, message/rfc822)
2005-10-12 11:04 PDT, Magnus Melin
no flags Details

Description sbrooks 2005-10-12 09:02:07 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

If you save an email with an inline image (i.e. using multipart/related with a
CID), and then use File|Open Saved Message, the image is not displayed.

Reproducible: Always

Steps to Reproduce:
1. Send yourself an HTML email with an image (i.e. using Insert|Image)
2. After receiving the email, save it to a file
3. Use File|Open Saved Message to reopen the email

Actual Results:  
When reopening the email, the image does not display.  I think you get the ALT
text instead.

Expected Results:  
The image should be displayed.
Comment 1 David :Bienvenu 2005-10-12 09:06:36 PDT
what version of thunderbird are you using? If you're not using 1.5 beta2, could
you try this with 1.5 beta 2? thx.
Comment 2 sbrooks 2005-10-12 09:16:30 PDT
I just tried it with 1.5 Beta 2, and it does not work.  I get a broken link, and
the image shows up as an attachment.
Comment 3 Magnus Melin 2005-10-12 11:03:22 PDT
Confirmed using 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051012
Thunderbird/1.4.1 ID:2005101205

Doesn't work in tb1.0.x either.
Comment 4 Magnus Melin 2005-10-12 11:04:55 PDT
Created attachment 199318 [details]
sample message
Comment 5 OstGote! 2005-10-12 12:23:25 PDT
Related to Bug 174692?
Comment 6 Magnus Melin 2005-10-12 12:33:53 PDT
(In reply to comment #5)
> Related to Bug 174692?

Looks like a dupe to me...

*** This bug has been marked as a duplicate of 174692 ***

Note You need to log in before you can comment on or make changes to this bug.