Closed Bug 312389 Opened 19 years ago Closed 19 years ago

download manager repeatedly warns there is no disk in drive A (floppy) when downloading to harddisk

Categories

(Toolkit :: Downloads API, defect)

1.7 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 153377

People

(Reporter: rainsjt, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Both at beginning of download and when download is complete, download manager
repeatedly opens warning window stating that there is no disk in drive A (3.5
floppy).  Regardless of whether I click "X" (to close window) or "cancel",
window comes back at least 4 times at beginning of download and at end.  In all
cases there is no disk in drive A, but I am not trying to download to drive A.

Reproducible: Always

Steps to Reproduce:
1.download a file with download manager
2.
3.

Actual Results:  
warning window for no disk in drive A (floppy) repeatedly (4 or more times at
beginning of download and 4 times at end of download) pops up regardless of
clicking "cancel". 

Expected Results:  
Not shown warning, since I was not downloading to the floppy drive, or at least
not come back after clicking "cancel".

I have used the floppy drive in other applications, including DOS window
After experiencing the exact same behavior in Windows XP pro with FireFox 1.0.6,
I renamed the FireFox downloads.rdf file and the behavior stopped.

The downloads.rdf file contained references to files which had been
downloaded directly to the floppy drive, <a:\>.

It is prossible, but not know, that an attempt was made to download
to the floppy drive but did not complete properly.


(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12)
Gecko/20050915 Firefox/1.0.7
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12)
Gecko/20050915 Firefox/1.0.7
> 
> Both at beginning of download and when download is complete, download manager
> repeatedly opens warning window stating that there is no disk in drive A (3.5
> floppy).  Regardless of whether I click "X" (to close window) or "cancel",
> window comes back at least 4 times at beginning of download and at end.  In all
> cases there is no disk in drive A, but I am not trying to download to drive A.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.download a file with download manager
> 2.
> 3.
> 
> Actual Results:  
> warning window for no disk in drive A (floppy) repeatedly (4 or more times at
> beginning of download and 4 times at end of download) pops up regardless of
> clicking "cancel". 
> 
> Expected Results:  
> Not shown warning, since I was not downloading to the floppy drive, or at least
> not come back after clicking "cancel".
> 
> I have used the floppy drive in other applications, including DOS window

After experiencing the exact same behavior in Windows XP pro with FireFox 1.0.6,
I renamed the FireFox downloads.rdf file and the behavior stopped.

The downloads.rdf file contained references to files which had been
downloaded directly to the floppy drive, <a:\>.

It is possible, but not known, that an attempt was made to download
to the floppy drive but did not complete properly.
--Rick
should be fixed with FF 1.5
see Bug 285497/Bug 153377 and bug 142664

*** This bug has been marked as a duplicate of 153377 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.