Closed Bug 153377 Opened 22 years ago Closed 19 years ago

No Disk popup in mozilla

Categories

(SeaMonkey :: UI Design, defect, P2)

x86
Windows 2000
defect

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey1.0beta

People

(Reporter: sfuhrman, Assigned: Biesinger)

References

Details

Attachments

(5 files, 1 obsolete file)

Hello,

I work at Hewlett-Packard and help test our software for our mid-end fibre
channel storage arrays.  Our software (HP Commandview), in addition to being
java based and running on win, linux, and hpux, also has a web interface.

As some of our software users will be linux users, I thought it would be
appropriate to test with Mozilla when testing the web interface to our problem.
 Of course, the problem is that there is not a public URL I can give you to let
you see our software.  I could possibly send you a copy, but the software must
not be spread as it is nearing release.

So basically, the software sets up a mini http server on port 4096.  Then it
loads a java program (JRE 1.3.1).  During this loading of all the java classes,
I get several popups that say 

"mozilla.exe - No Disk
There is no disk in the drive.  Please insert a disk into drive A:"

I am not sure why it is asking for a floppy, but thought you guys might now.  If
this is something you want to tackle let me know.

I have tested it with the official 1.0 release and it worked fine there.  This
seems to be only on the 1.1 Alpha.

Thanks,

Scott

sfuhrman@newmail.net
scott_fuhrman@non.hp.com
-> Oji

Which JRE do you use ?
Assignee: Matti99 → joe.chou
Component: Browser-General → OJI
QA Contact: imajes-qa → pmac
Have you tested using JRE1.4 or 1.4.0_01?
This appears every time I click File/New/Navigator Window, not just Java pages
Only when the disk drive is emtpy (E:drive in my case which is the ZIP drive)
I have to click on Abort 20 times before the new window will come up. (10 times
before the new window and 10 times after the new window come up)
If I have a disk in the drive the popup window does not appear.

Windows NT 4sp6, Mozilla build 2002053012

JP Lande
Per comment #3, this happened on all pages, not just java. So it looks like a
window loading problem. Re-assign to widget.
Also, per the description from the reporter (at the end), this only happened in
1.1a+, but worked OK in 1.0. Sounds like a regression.
Assignee: joe.chou → rods
Component: OJI → XP Toolkit/Widgets
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla1.0.1
I see this on my XP machine, and thought maybe it was just an issue with it.
This makes the browser completely unusable. I think it is a RTM stop ship.

I am unable to pull the commercial build (because of a problem with sera) so I
am not sure where to even start on this.
Keywords: nsbeta1
I am seeing this on WinXP Pro. It asked for the CD drive, "F:", from which I
took a CD out minutes before this dialog popped up. My browser's u-a string:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020624
Netscape/7.0 
This is not OJI issue based on comment #3, change qa contact to John Morrison.
QA Contact: pmac → jrgm
Summary: No Disk popup in mozilla when viewing java page → No Disk popup in mozilla
could this be related to bug 142664?
Component: XP Toolkit/Widgets → RDF
Attached file stack trace
It looks like it is trying load a file that I had once a long time ago dropped
into the browser from my "A" drive.

This is a trunk and branch issue.
-->
Assignee: rods → waterson
Status: ASSIGNED → NEW
Hey Rod. When you break at that stack, can you see, in one of the JS frames
(maybe js_Interpret) what the name is of the script that is executing?
There isn't much script that's run from a timeout on browser window open and
even less that causes a rebuild. I suspect this is LoadBookmarksCallback in
navigator.js, which means we're loading the bookmarks and populating the
personal toolbar. Why we're going to disk (other than loading the
bookmarks.html) I don't know. Maybe we're trying to sniff the file to see what
icon to display for it (Windows only)?
Sorry for not updating earlier. Rod and I spoke and (at least) his problem was
a link to a file on a not-available floppy that was placed in his personal 
toolbar. (Jag wins a prize for predictive capabilities :-). This would also 
apply to a CD that is removed, but it appears that a resource on an unmounted 
windows drive is not a problem. 

I'm not sure why this fired on a timer before. But anyways, the workaround 
is to remove any file:// urls in your personal toolbar. (This can also affect 
you if you just have a bookmark to a file on  removed drive, or if you try
to access it from the history dropdown in the urlbar, but it's less annoying
[fewer prompts] in those cases. 

There doesn't appear to be an easy fix for this. Here are the three different 
call stacks that trigger that prompt.

Sidenote: I'm not sure though that we haven't gone astray from the original 
bug report. This started with a particular Java app -- "During this loading of 
all the java classes, I get several popups that say "mozilla.exe - No Disk
There is no disk in the drive.  Please insert a disk into drive A:"

That doesn't sound like the personal toolbar. 

------------------------------------------------------------------------
NTDLL! 77f8b5bf()
KERNEL32! 77e88e05()
NSPR4! _PR_MD_GETFILEINFO64 + 78 bytes
NSPR4! PR_GetFileInfo64 + 27 bytes
nsLocalFile::ResolveAndStat(nsLocalFile * const 0x1004dec0 const  
nsLocalFile::`vftable', int 0x00000001) line 616 + 11 bytes
nsLocalFile::IsDirectory(nsLocalFile * const 0x029d9ac8, int * 0x0012f80c) line 
1732
FileSystemDataSource::isDirURI(nsIRDFResource * 0x02c6a6d0) line 256
FileSystemDataSource::ArcLabelsOut(FileSystemDataSource * const 0x022cc7c0, 
nsIRDFResource * 0x02c6a680, nsISimpleEnumerator * * 0x02c6a554) line 974 + 6 
bytes
CompositeArcsInOutEnumeratorImpl::GetEnumerator(CompositeArcsInOutEnumeratorImp
l * const 0x00f51f08, nsIRDFDataSource * 0x022cc7c0, nsISimpleEnumerator * * 
0x02c6a554) line 450 + 15 bytes
CompositeEnumeratorImpl::HasMoreElements(CompositeEnumeratorImpl * const 
0x00000004, int * 0x0012f8c8) line 240
nsRDFConInstanceTestNode::FilterInstantiations(const nsRDFConInstanceTestNode * 
const 0x00f51f08, InstantiationSet & {...}, void * 0x0012f9cc) line 228
TestNode::Propagate(TestNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 1045
TestNode::Propagate(TestNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 1053 + 14 bytes
TestNode::Propagate(TestNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 1053 + 14 bytes
TestNode::Propagate(TestNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 1053 + 14 bytes
RootNode::Propagate(RootNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 760 + 15 bytes
nsXULContentBuilder::CreateContainerContents(nsXULContentBuilder * const 
0x00f51f08, nsIContent * 0x02cf7438, nsIRDFResource * 0x02cf7438, int 
0x00000000, nsIContent * * 0x00000000, int * 0x00000000) line 1298
...

NTDLL! 77f8b5bf()
KERNEL32! 77e88e05()
NSPR4! _PR_MD_GETFILEINFO64 + 78 bytes
NSPR4! PR_GetFileInfo64 + 27 bytes
nsLocalFile::ResolveAndStat(nsLocalFile * const 0x1004dec0 const  
nsLocalFile::`vftable', int 0x00000001) line 616 + 11 bytes
nsLocalFile::IsDirectory(nsLocalFile * const 0x029d9ac8, int * 0x0012f80c) line 
1732
FileSystemDataSource::isDirURI(nsIRDFResource * 0x02c6a680) line 256
FileSystemDataSource::GetFolderList(nsIRDFResource * 0x022d4f70, int 
0x00000000, int 0x00000001, nsISimpleEnumerator * * 0x0012f858) line 1265 + 8 
bytes
FileSystemDataSource::GetTarget(FileSystemDataSource * const 0x022cc7c0, 
nsIRDFResource * 0x022d4f70, nsIRDFResource * 0x00000000, int 0x00000001, 
nsIRDFNode * * 0x0012f8ec) line 600
CompositeDataSourceImpl::GetTarget(CompositeDataSourceImpl * const 0x02c8ed38, 
nsIRDFResource * 0x022d4f70, nsIRDFResource * 0x00f1b638, int 0x00000001, 
nsIRDFNode * * 0x00000002) line 832
nsRDFConInstanceTestNode::FilterInstantiations(const nsRDFConInstanceTestNode * 
const 0x00f51f08, InstantiationSet & {...}, void * 0x0012f9cc) line 177
TestNode::Propagate(TestNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 1045
TestNode::Propagate(TestNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 1053 + 14 bytes
TestNode::Propagate(TestNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 1053 + 14 bytes
TestNode::Propagate(TestNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 1053 + 14 bytes
RootNode::Propagate(RootNode * const 0x00f51f08, const InstantiationSet & 
{...}, void * 0x0012f9cc) line 760 + 15 bytes
nsXULContentBuilder::CreateContainerContents(nsXULContentBuilder * const 
0x00f51f08, nsIContent * 0x02cf7438, nsIRDFResource * 0x02cf7438, int 
0x00000000, nsIContent * * 0x00000000, int * 0x00000000) line 1298
...

NTDLL! 77f8b5bf()
KERNEL32! 77e88e05()
NSPR4! _PR_MD_GETFILEINFO64 + 78 bytes
NSPR4! PR_GetFileInfo64 + 27 bytes
nsLocalFile::ResolveAndStat(nsLocalFile * const 0x1004dec0 const  
nsLocalFile::`vftable', int 0x00000001) line 616 + 11 bytes
nsLocalFile::IsDirectory(nsLocalFile * const 0x029d9ac8, int * 0x0012f80c) line 
1732
FileSystemDataSource::isDirURI(nsIRDFResource * 0x02c6aef8) line 256
FileSystemDataSource::HasArcOut(FileSystemDataSource * const 0x022cc7c0, 
nsIRDFResource * 0x022d4f70, nsIRDFResource * 0x00f1b638, int * 0x0012f2f0) 
line 906 + 8 bytes
CompositeDataSourceImpl::HasArcOut(CompositeDataSourceImpl * const 0x02c8ed38, 
nsIRDFResource * 0x022d4f70, nsIRDFResource * 0x00f1b638, int * 0x00000005) 
line 1222
nsXULTemplateBuilder::CheckContainer(nsXULTemplateBuilder * const 0x00f51f08, 
nsIRDFResource * 0x022d4f70, int * 0x0012f940, int * 0x0012f924) line 1321
nsXULContentBuilder::BuildContentFromTemplate(nsXULContentBuilder * const 
0x00f51f08, nsIContent * 0x02c78ea8, nsIContent * 0x02cf7438, nsIContent * 
0x02cf7438, int 0x00000001, nsIRDFResource * 0x022d4f70, int 0x00000000, 
nsTemplateMatch * 0x02ac4b58, nsIContent * * 0x00000000, int * 0x00000000) line 
682
nsXULContentBuilder::CreateContainerContents(nsXULContentBuilder * const 
0x00f51f08, nsIContent * 0x02cf7438, nsIRDFResource * 0x02cf7438, int 
0x00000000, nsIContent * * 0x00000000, int * 0x00000000) line 1322
nsXULContentBuilder::CreateTemplateAndContainerContents(nsXULContentBuilder * 
const 0x00f51f08, nsIContent * 0x02cf7438, nsIContent * * 0x022cb718, int * 
0x00000000) line 1217
nsXULContentBuilder::CreateContents(nsXULContentBuilder * const 0x02ac4818, 
nsIContent * 0x02cf7438) line 1765
nsXULElement::EnsureContentsGenerated(const nsXULElement * const 0x00f51f08) 
line 3640 + 10 bytes
nsXULElement::ChildAt(const nsXULElement * const 0x02cf7438, int 0x00000001, 
nsIContent * & 0x00000000) line 2186 + 10 bytes
nsXULDocument::AddSubtreeToDocument(nsXULDocument * const 0x02c4b104, 
nsIContent * 0x00000001) line 3858
...

Attached image Screenshot of the popup
This is on Win2k Advanced Server, loading a java applet, Moz1.1a.
I am using JRE 1.3.1 when this happens while trying to load the java applet.
Hey Scott, can we do a simple test to distinguish whether your problem is the
same problem noted in comment #13? 

Can you start mozilla (independent of running your applet) then open the 
bookmark manager (Bookmarks->Manage Bookmarks) and then open the search 
bookmarks dialog (Tools->Search Bookmarks in the bookmarks window). 
Look for ['location' 'contains' 'file:'] to find file URLs stored in 
bookmarks. Do any of those (if any exist) point to an unmounted floppy,
CD drive or network drive?

Status: NEW → ASSIGNED
Keywords: helpwanted
Priority: -- → P3
Target Milestone: mozilla1.0.1 → Future
I noticed a problem today which could be similar to this bug, but I'm not sure.
 Tell me what you think:

Steps to reproduce:
1. Load http://fsc-pc.de/SecurityCD/E/SmartCardReader.htm
   As page loads, dialog pops up saying "There is no disk in the drive.  Please
insert a disk into drive \Device\Harddisk1\DR3."
2. Dismiss.  Dialog will pop up four more times before it goes away.  

I have no way of testing to see if this problem occurrs on any other machine
besides my own.  I am running WinXP Pro, Moz1.1b Build 2002072104.
Occurs in my environment (WinXP Pro SP 1) as:
There is no disk in the drive.  Please insert a disk in drive E:.

Drive E is 2nd CD-ROM in my system
Mozilla 2003022308 WinNT4, 1.3b W2K

I stumbled across this problem sometimes. As I understand it the problem are the
file links in such pages/applets.

URL from comment 17 contains one local image:
img border="0"
src="file:///J:/www_Security/SecurityCD/Bilder/_von_TechnCD/Button/Readme.gif"

another example with a local link:
http://people.freenet.de/cgd1yu25/sunshine5.html contains
img
src="file:///I|/-=SONSTIGE=-/MP3_GALAXY_PAGE/13.Mai/MP3_Galaxy_Page/mixe/dot.gif"

The dialog appears only if you satisfy all the following conditions:
- you have a drive with such a letter
- there is no media in that drive
(I think it occurs only on removable drives, not on network drives/shares)

My opinion:
A bug for "Mozilla shows me a dialog" is invalid because it is ok (in general).
But in the case of image source-links like in the two URLs above Mozilla should
not display any message.
The real problem is that Mozilla displays the dialog more than once, even if
you've selected cancel. Related bugs are 127386, 142664, and 193353.

What I wonder about is the effect of the pref security.checkloaduri (see
http://www.mozilla.org/releases/mozilla1.3b/#psm). Is this pref only for
"active" content such html/js and not for images? I don't get any security
errors in the JS console. 

But if I try to save ("Save As ...") one of the local images in "View Page Info
- Media" for the examples above I got 

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIURIChecker.asyncCheckURI]"  nsresult:
"0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://communicator/content/contentAreaUtils.js :: nsHeaderSniffer :: line
402"  data: no]

in the JS console.

Hope this helps. BTW I would change the summary to "No Disk popup/dialog in
Mozilla" to make it easier to find.
Running Windows XP SP1
Clean install of Mozilla 1.3

I have the same problem. Sometimes I go on a web page and boom! I get this
dialog box continually popping. Here some additional information regarding this bug.

- No file on my computer contains a reference or a link to the D: drive.
- Problem also occurs in Mozilla 1.2.1.
- Tables in pages that produce the error appear to be almost infinite. If I
click on the down arrow on the vertical scroll bar, it takes 3 seconds for it to
move 1 pixel down. And I am in 1024x768.
- I have created a D: partition. The popups stopped but the pages still don't
render correctly.

I will attach three screen shots:
  1- http://groups.yahoo.com in Mozilla 1.3: no problem
  2- http://cf.groups.yahoo.com in Mozilla 1.3: has the bug; see the size of the
scroll bar cursor
  3- http://cf.groups.yahoo.com in Explorer 6: no problem

I am available to do further tests if need be.
Gou: your sites WFM with Moz 1.4b build 2003042112 and 2003040808 on WinNT4.
I installed today's nightly, went to cf.groups.yahoo.com, and it works. Bring
back 1.3, and it works. Go figure. Must have been a fat electron.
adt: nsbeta1-
Keywords: nsbeta1nsbeta1-
Reassign to default component owner, since I'm not actively working on Mozilla
right now.
Assignee: waterson → rjc
Status: ASSIGNED → NEW
This also occurs on Firebird (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.6a) Gecko/20031107 Firebird/0.7+; running on Win2K sp4). This never
happened until I got a USB smart card reader that has slots for multiple types
of media. If the reader is plugged in and one or more "slots" are empty (which
is always the case), I get the same error.
IMHO this bug could be duped against the new and clean Bug 206459 which is about
to avoid such a dialog/popup.
Depends on: 206459

*** This bug has been marked as a duplicate of 206459 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** Bug 245059 has been marked as a duplicate of this bug. ***
Status: RESOLVED → REOPENED
Component: RDF → NSPR
Product: Browser → NSPR
Resolution: DUPLICATE → ---
Target Milestone: Future → ---
Version: Trunk → other
No longer depends on: 206459
Assignee: rjc → wchang0222
Status: REOPENED → NEW
QA Contact: jrgmorrison → wchang0222
This is painful and not worth doing, but it should work.

The right fix is for something early in init to just call the function once and
for everyone else to promise never to call it.
Attachment #151621 - Flags: review?(wchang0222)
Comment on attachment 151621 [details] [diff] [review]
Wrap FindFirstFile/FindNextFile

timeless, I agree with you that SetErrorMode should be
called by an application during its initialization.  A
library like NSPR should not mess with SetErrorMode.
So I am marking this patch review-.
Attachment #151621 - Flags: review?(wchang0222) → review-
*** Bug 255490 has been marked as a duplicate of this bug. ***
*** Bug 259962 has been marked as a duplicate of this bug. ***
*** Bug 255203 has been marked as a duplicate of this bug. ***
*** Bug 262278 has been marked as a duplicate of this bug. ***
(In reply to comment #32)
> (From update of attachment 151621 [details] [diff] [review])
> timeless, I agree with you that SetErrorMode should be
> called by an application during its initialization.  A
> library like NSPR should not mess with SetErrorMode.
> So I am marking this patch review-.
> 

How long does it take to do a patch review and subsequent fix. Not complaining,
just curious as this is still prevailing in Firefox PR-1
afaict this bug is due to a link in the bookmarks.html that points to a non
existing drive
(In reply to comment #38)
> afaict this bug is due to a link in the bookmarks.html that points to a non
> existing drive

Already discovered here that is not the case in my Firefox. I can manually type
in a URL and this error occurs.
*** Bug 259401 has been marked as a duplicate of this bug. ***
*** Bug 269016 has been marked as a duplicate of this bug. ***
*** Bug 280539 has been marked as a duplicate of this bug. ***
*** Bug 287839 has been marked as a duplicate of this bug. ***
*** Bug 255070 has been marked as a duplicate of this bug. ***
*** Bug 268769 has been marked as a duplicate of this bug. ***
bug 278328 WONTFIXed this in NSPR, so moving this bug to mozilla app. suite (bug
285497 did this for the toolkit-based applications).
Assignee: wtchang → cbiesinger
Component: NSPR → XP Apps
Product: NSPR → Mozilla Application Suite
Version: other → Trunk
Attached patch patch (obsolete) — Splinter Review
Attachment #181280 - Flags: superreview?(jag)
Attachment #181280 - Flags: review?(neil.parkwaycc.co.uk)
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: --- → Seamonkey1.0beta
Comment on attachment 181280 [details] [diff] [review]
patch

Only using a nested #ifdef DEBUG for the second block is a bit inconsistent...
Attachment #181280 - Flags: review?(neil.parkwaycc.co.uk) → review+
Comment on attachment 181280 [details] [diff] [review]
patch

+#ifdef WIN32

Wouldn't you want XP_WIN32 for consistency?

And like Neil said, it'd be cleaner to make the first change look like this:

#ifdef XP_WIN32
#include <windows.h>

#if defined(DEBUG)
#include <malloc.h>
#endif

#endif

sr=jag with those two nits fixed.
Attachment #181280 - Flags: superreview?(jag) → superreview+
Attached patch patch v2Splinter Review
comments addressed. XP_WIN32 is what I meant to type :/

This is a low-risk patch affecting seamonkey only. It ports a toolkit patch.
Attachment #181280 - Attachment is obsolete: true
Attachment #181345 - Flags: approval1.8b2?
Comment on attachment 181345 [details] [diff] [review]
patch v2

a=asa
Attachment #181345 - Flags: approval1.8b2? → approval1.8b2+
Checking in xpfe/bootstrap/nsAppRunner.cpp;
/cvsroot/mozilla/xpfe/bootstrap/nsAppRunner.cpp,v  <--  nsAppRunner.cpp
new revision: 1.439; previous revision: 1.438
done

Status: ASSIGNED → RESOLVED
Closed: 21 years ago19 years ago
Keywords: helpwanted
Resolution: --- → FIXED
*** Bug 309356 has been marked as a duplicate of this bug. ***
*** Bug 312389 has been marked as a duplicate of this bug. ***
*** Bug 353439 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: