New message arriving when threads sorted by date does not change thread order

RESOLVED DUPLICATE of bug 262319

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 262319
13 years ago
13 years ago

People

(Reporter: Rolf Campbell, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Thunderbird version 1.5 Beta 2 (20051006)

A newsgroup or IMAP email account with threaded view, sorted by date, descending
order correctly arranges the threads by the newest message in a thread but if a
new message shows up in an old thread, hitting the "Get Mail" (or Control+T on
windows) will not re-arrange the threads to compensate for the new message. 
Causing a complete refresh by selecting a different newsgroup/mailbox and then
moving back to the original one shows the correct thread order.

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird to your mailbox (only tested on IMAP/NNTP, probably works on
POP too)
2. View->Sort by->Threaded
3. View->Sort by->Date
4. View->Sort by->Descending
5. Send yourself 3 emails (test1, test2, test3).  They will be displayed in this
order ["test3", "test2", "test1"].  
6. Reply to the test2 message.
Actual Results:  
The order did not change ["test3", "+test2", "test1"].
I had to close and re-open that mail folder to make the threads display in the
correct order ["+test2", "test3", "test1"]

Expected Results:  
During step 6, reception of the reply to "test2" should have immediately changed
the thread order to ["+test2", "test3", "test1"]

Comment 1

13 years ago
(In reply to comment #0)
This same bug happens on Thunderbird 1.0.7 (20050923) using Linux.

Comment 2

13 years ago
Duplicate of bug 262319?

Comment 3

13 years ago
(In reply to comment #2)
> Duplicate of bug 262319?

You have to ask?  :)

*** This bug has been marked as a duplicate of 262319 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.