Last Comment Bug 312680 - unknown protocol error produces dialog instead of error page
: unknown protocol error produces dialog instead of error page
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All All
: -- normal with 3 votes (vote)
: mozilla13
Assigned To: O. Atsushi (Torisugari)
:
: Andrew Overholt [:overholt]
Mentors:
foo://heck
: 325839 479122 599662 621343 (view as bug list)
Depends on: 291876 311007
Blocks: 382702
  Show dependency treegraph
 
Reported: 2005-10-16 19:47 PDT by James Darpinian
Modified: 2014-02-05 07:46 PST (History)
20 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1009 bytes, patch)
2011-06-09 03:36 PDT, O. Atsushi (Torisugari)
cbiesinger: review+
Details | Diff | Splinter Review

Description James Darpinian 2005-10-16 19:47:49 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051016 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051016 Firefox/1.4.1

Visiting a URL with an unknown protocol specified results in an annoying dialog
box instead of a nice error page.  The dialog is in the style of old Firefox 1.0
errors, from before error pages were switched on by deafult.

Reproducible: Always

Steps to Reproduce:
Comment 1 Mike Connor [:mconnor] 2005-10-16 21:22:31 PDT
This is an intentional workaround for a more serious bug, which won't be fixable
in the 1.5 timeframe.
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2005-10-16 21:24:12 PDT
Bug 307027 is the more serious bug.
Comment 3 Jesse Ruderman 2005-10-28 19:21:18 PDT
That doesn't make this bug invalid, just not fixable for 1.5.

Btw, the other bug was fixed for 1.5.
Comment 4 Bob Clary [:bc:] 2005-10-28 19:35:06 PDT
This hits me during automated testing.
Comment 5 Julian D. A. Wiseman 2006-02-02 11:11:16 PST
A related but easier request has been made in bug 325622.
Comment 6 Chris Lawson (gone) 2006-03-16 19:46:59 PST
*** Bug 325839 has been marked as a duplicate of this bug. ***
Comment 7 Jesse Ruderman 2009-07-28 00:12:37 PDT
*** Bug 479122 has been marked as a duplicate of this bug. ***
Comment 8 Gábor Stefanik 2010-08-29 13:43:02 PDT
I believe the original problem here was https://bugzilla.mozilla.org/show_bug.cgi?id=306409, which is now fixed. Is this fixable now?
Comment 9 O. Atsushi (Torisugari) 2011-06-09 03:36:59 PDT
Created attachment 538230 [details] [diff] [review]
Patch v1

Let's backout the patch by bug 307027 (attachment 198362 [details] [diff] [review]).
Comment 10 Christian :Biesinger (don't email me, ping me on IRC) 2011-06-10 13:07:04 PDT
Comment on attachment 538230 [details] [diff] [review]
Patch v1

Seems the original problem was bug 307027 comment 8. Do you have an indication that that one is fixed now? Or have you tested that that bug doesn't occur anymore with this patch?
Comment 11 Christian :Biesinger (don't email me, ping me on IRC) 2011-06-21 06:34:02 PDT
Comment on attachment 538230 [details] [diff] [review]
Patch v1

I'm going to mark this r- pending a reply to my last comment
Comment 12 Gábor Stefanik 2011-11-11 07:23:33 PST
(In reply to Christian :Biesinger (don't email me, ping me on IRC) from comment #10)
> Comment on attachment 538230 [details] [diff] [review] [diff] [details] [review]
> Patch v1
> 
> Seems the original problem was bug 307027 comment 8. Do you have an
> indication that that one is fixed now? Or have you tested that that bug
> doesn't occur anymore with this patch?

Comment 8 basically appears to be bug 311007, which is fixed now.
Comment 13 O. Atsushi (Torisugari) 2011-12-14 02:01:42 PST
I was not in the CC list for some reason. I'm sorry.

(In reply to Christian :Biesinger (don't email me, ping me on IRC) from comment #10)
> Seems the original problem was bug 307027 comment 8. Do you have an
> indication that that one is fixed now?

On trunk, yes. Even if bug 307027 happened to regress, now we can detect it easily;
http://mxr.mozilla.org/mozilla-central/source/docshell/test/chrome/bug311007_window.xul
Comment 14 O. Atsushi (Torisugari) 2011-12-15 08:27:31 PST
*** Bug 621343 has been marked as a duplicate of this bug. ***
Comment 15 Christian :Biesinger (don't email me, ping me on IRC) 2012-02-10 14:03:31 PST
Comment on attachment 538230 [details] [diff] [review]
Patch v1

ok, sounds good. if we run into problems again, we can always revert this.

my apologies for the delay.
Comment 16 O. Atsushi (Torisugari) 2012-02-11 03:33:15 PST
Thanks.

Requesting checkin;

"Bug 312680 - Back out bug 307027, for bug 311007 is fixed, r=cbiesinger"
Comment 18 Marco Bonardo [::mak] 2012-02-16 03:03:15 PST
https://hg.mozilla.org/mozilla-central/rev/e8d87ff90d0f
Comment 19 O. Atsushi (Torisugari) 2014-02-05 07:46:47 PST
*** Bug 599662 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.