Reply to mail with huge .txt attachments causes edit window to take "forever" to respond.

RESOLVED DUPLICATE of bug 161775

Status

--
minor
RESOLVED DUPLICATE of bug 161775
13 years ago
13 years ago

People

(Reporter: summand, Assigned: mscott)

Tracking

x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

I frequently get mails with ".txt" attachments with 2 MB or more. When I click
Reply, the whole txt file is inserted into the replymail as quoted text. This
takes a lot of time.

Also, I don't want to quote 11.000 lines of a log file.

Reproducible: Always

Steps to Reproduce:
1. Send a email with a 2 MB txt file to yourself
2. When you receive it, click Reply
Actual Results:  
I had to wait a few minutes before Thunderbird responded again.

Expected Results:  
Several things are possible:

1) Do not quote txt files in a reply. You do not do this with other attachments,
so it is consistent IMHO. This is my prefered solution.
2) Ask if I want to quote txt files (with "Remember my decision" maybe)
3) Open a "Please wait" box, put it in another thread and at least don't block
the main application.

Anyway, at least the mainwindow should not get unresponsive.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0

Comment 1

13 years ago
(In reply to comment #0)
> 1) Do not quote txt files in a reply. You do not do this with other
> attachments, so it is consistent IMHO. This is my prefered solution.

Yes, that is the best solution.  Note that any text displayed inline (not just 
.txt attachments, also e.g. .eml or .html attachments) are quoted.  And if you 
reply in HTML mode, any image attachments shown inline are quoted.

As noted at the dupe, the workaround is to turn off  View|Display Attachments 
Inline  prior to hitting Reply.

*** This bug has been marked as a duplicate of 161775 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.