Add alternate menu item and keyboard shortcut for "Reload All Tabs"

VERIFIED FIXED

Status

Camino Graveyard
Toolbars & Menus
--
enhancement
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: froodian (Ian Leue))

Tracking

({fixed1.8.1})

Details

Follow-up to bug 175863:

Lots of people want a keyboard shortcut for the "reload all tabs" action
(currently only on the tab context menu).  The cleanest way to do this seems to
be with Cmd-Opt-R and have the "Reload Page" menu item change name and shortcut
when Opt is held down, which requires we drop support for 10.2 first (alternate
menu items).

Comment 1

12 years ago
Or you could just add a Mainmenu item for reload all tabs and hook it up to
Shift-Command-R, that should work just as good.

Comment 2

12 years ago
Ugh never mind that comment :) We use shift for force reload already, duh!

Comment 3

12 years ago
I'd say:

Normal -> Reload
Shift -> Force Reload
Option -> Reload All Tabs
Shift-Option -> Force Reload All Tabs

or something like that.

Comment 4

12 years ago
Is this not a duplicate of Bug 216083?
(In reply to comment #4)
> Is this not a duplicate of Bug 216083?

No, Camino's UI is completely from that of the XUL apps.
Blocks: 328173
(Assignee)

Comment 6

11 years ago
The patch for this is in bug 181978
Depends on: 181978
QA Contact: toolbars
(Assignee)

Updated

11 years ago
Assignee: mikepinkerton → stridey
Fixed (branch/trunk) by the checkin for bug 181978.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.