Closed Bug 31299 Opened 21 years ago Closed 21 years ago

Visibility with forms.

Categories

(Core :: CSS Parsing and Computation, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 13047

People

(Reporter: mgalli, Assigned: pierre)

References

()

Details

Attachments

(1 file)

Build: 2000030516, also 2000030909
Win98.

See the url. Let the animation bring the panel to the screen. See that 
there is nothing in the blue area. Click the mouse in the center of 
the blue area.. see that there is a form. 

The form was created in HTML, with div and style...visibility:hidden. 
Then the visibility was changed to visible. And nothing happens until 
you click or cause some repaint. 

For example, try again but now.. alternate windows with alt+tab and alt+tab 
again...
This is a dup of bug 13047. Same testcase: a DIV with style="visibility:hidden;" 

and a script that changes the visibility.



FYI, there is a workaround. The reporter wrote in 13047: If I leave out 

"visiblity:hidden;" I can freely switch the visibility between "hidden" and 

"visible".


*** This bug has been marked as a duplicate of 13047 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Summary: Visibility with forms. → Visibility with forms.
This bug is in fact invalid. The width and height should not have been applied to 
the <form> element but to its parent, the "areaform" <div> element. See the fixed 
page that I'm going to attach.

- I understand it was a bit confusing because many workarounds were possible.
- I file a related problem under bug 41188
Attached file fixed page
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.