Last Comment Bug 313018 - select1 size incorrect when populate from itemset
: select1 size incorrect when populate from itemset
Status: RESOLVED FIXED
: fixed1.8
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug]
: Stephen Pride
Mentors:
: 312301 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-19 09:01 PDT by Nick Jones
Modified: 2016-07-15 14:46 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
select1 populate by item (1.30 KB, application/xhtml+xml)
2005-10-19 09:02 PDT, Nick Jones
no flags Details
select1 populate by itemset (1.30 KB, application/xhtml+xml)
2005-10-19 09:08 PDT, Nick Jones
no flags Details
proposed patch (867 bytes, patch)
2005-10-19 13:22 PDT, Olli Pettay [:smaug]
doronr: review+
aaronr: review+
Details | Diff | Splinter Review
proposed patch for 1.8 (1.80 KB, patch)
2005-10-24 12:47 PDT, Olli Pettay [:smaug]
doronr: review+
aaronr: review+
Details | Diff | Splinter Review
Testcase with default value (1.31 KB, application/xhtml+xml)
2006-04-19 14:35 PDT, Charles Brunet
no flags Details

Description Nick Jones 2005-10-19 09:01:14 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511

select1 does not resize to contain text when populated from itemset. It does
when populate by a series of item tags.

Reproducible: Always
Comment 1 Nick Jones 2005-10-19 09:02:31 PDT
Created attachment 200092 [details]
select1 populate by item
Comment 2 Nick Jones 2005-10-19 09:08:31 PDT
Created attachment 200093 [details]
select1 populate by itemset
Comment 3 Olli Pettay [:smaug] 2005-10-19 13:23:01 PDT
Created attachment 200130 [details] [diff] [review]
proposed patch
Comment 4 Olli Pettay [:smaug] 2005-10-19 13:26:03 PDT
Comment on attachment 200130 [details] [diff] [review]
proposed patch

The C++ part of the itemset is nowadays nsXFormsDelegate, so the UI part can
now implement nsIXFormsUIWidget and get all the fixes related to PostRefresh.
Comment 5 aaronr 2005-10-19 22:42:12 PDT
Comment on attachment 200130 [details] [diff] [review]
proposed patch

I don't have a problem with the patch, but I don't see any difference with the
attached testcases before or after I compile in the patch.  Is there a more
obvious testcase?
Comment 6 Olli Pettay [:smaug] 2005-10-20 07:33:12 PDT
(In reply to comment #5)
> (From update of attachment 200130 [details] [diff] [review] [edit])
> I don't have a problem with the patch, but I don't see any difference with the
> attached testcases before or after I compile in the patch.  Is there a more
> obvious testcase?
> 

Hmm, the patch should fix the problem with the second test case.

Comment 7 Olli Pettay [:smaug] 2005-10-20 08:34:01 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > (From update of attachment 200130 [details] [diff] [review] [edit] [edit])
> Hmm, the patch should fix the problem with the second test case.

And this fixes the size problem in bug 312301.

Comment 8 Olli Pettay [:smaug] 2005-10-20 08:37:58 PDT
checked in to trunk
Comment 9 Olli Pettay [:smaug] 2005-10-20 08:38:48 PDT
*** Bug 312301 has been marked as a duplicate of this bug. ***
Comment 10 Doron Rosenberg (IBM) 2005-10-21 11:08:04 PDT
Hmm, on branch, this patch doesn't seem to fix the issue for me.
Comment 11 aaronr 2005-10-21 13:34:46 PDT
(In reply to comment #10)
> Hmm, on branch, this patch doesn't seem to fix the issue for me.

Nope, doesn't work on branch for me either.
Comment 12 Olli Pettay [:smaug] 2005-10-23 14:17:41 PDT
(In reply to comment #10)
> Hmm, on branch, this patch doesn't seem to fix the issue for me.
> 

Strange. I'll look at it tomorrow. (Way too late atm.)
Does the patch still fix Bug 312301?

Comment 13 Olli Pettay [:smaug] 2005-10-24 12:47:07 PDT
Created attachment 200636 [details] [diff] [review]
proposed patch for 1.8

I have no idea why the select->Refresh(); was commented out o_O
Comment 14 Doron Rosenberg (IBM) 2005-10-24 13:56:12 PDT
checked into branch
Comment 15 Charles Brunet 2006-04-19 14:35:30 PDT
Created attachment 219066 [details]
Testcase with default value

select1 size is incorrect when a default value is given.
Comment 16 aaronr 2006-04-19 15:04:56 PDT
(In reply to comment #15)
> Created an attachment (id=219066) [edit]
> Testcase with default value
> 
> select1 size is incorrect when a default value is given.
> 

This works fine on the trunk.  Fixed by bug 333045 which didn't make it into 0.5.  Will be in 0.6.

Note You need to log in before you can comment on or make changes to this bug.