Closed Bug 313342 Opened 14 years ago Closed 4 years ago

Multiple scrollable frames for folder view

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1163555

People

(Reporter: ian.graham, Unassigned)

References

()

Details

(Whiteboard: workarounds: favorites, https://addons.mozilla.org/en-US/thunderbird/addon/4222)

When I have lots of local folders, I get really frustrated scrolling up and down
from the remote folders to the local folders, and back again. For example, if I
want to move mail from my inbox to some local folder I need to:

a) scroll up to the inbox
b) select the message
c) scroll down to the desired local folder
d) move the message to the desired folder
e) scroll back up to the inbox
f) select the inbox to view incoming mail.

It would be nice if, instead, there were two folder panes: one containing the
remote folders, and the other the local ones. e.g.

----------------------
|- Remote folders  |X|
|  - INnbox (23)   |X|
|  - Sent          | |
|  - Trash         | |
|  - xxxxx         | |
----------------------
|- Local folders   | |
|  - folder 1      | |
|    + subfolder   | |
|  - folders       | |
|  + folderX       |X|
|  -folderaaa      |X|
|  -folderab       | |
|  -folderCC       | |
|  -folderdD       | |
|  -folderEE       | |
----------------------

Then I can 

a) scroll up to the inbox in the remote folder pane
b) scroll down to the local folder in the local folder pane
c) move the message to the desired folder in the local folder pane
d) re-select the inbox in the remote folder pane

saving several scrolling steps, and making my life easier and more intuitive.

This would in principle work for multiple remote servers.
This may be related to bug 251296 
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
QA Contact: front-end
Duplicate of this bug: 339065
Achievable today by the extension Additional Folders View, which does just that, split folder pane in 2 with independent view (all, fav etc) and separate scroll.

(Another workaround being to open a new window and drag from one to another..
Could have been resolved by favorites or other views too, comment 1)


Now the question remains, should this stay as extension or move to core? Cause staying as extension means Works For Me .. 
Assignee: mscott → nobody
Whiteboard: workarounds: favorites, https://addons.mozilla.org/en-US/thunderbird/addon/4222
Thanks. I am not sure, though, that an unsupported extension is a satisfactory alternative to what I think is an valuable core capability.
(In reply to comment #4)
> Thanks. I am not sure, though, that an unsupported extension is a satisfactory
> alternative to what I think is an valuable core capability.

What you think is a valuable core capability may be useless bloat to other people. Indeed, part of the reasoning behind Thunderbird is to make it extensible such that not everyone is saddled with features that few will use.
I am fine with this being an extension. But I am not fine with marking this WFM based on their being a 2 year old unsupported extension offering not quite the same capabilities. T
Covered in a more-general way in bug 1163555.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1163555
You need to log in before you can comment on or make changes to this bug.