Closed Bug 313365 Opened 16 years ago Closed 15 years ago

Bidi: RTL textareas with a vertical scrollbar always have a horizontal scrollbar as well

Categories

(Core :: Layout: Form Controls, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: uriber, Unassigned)

References

Details

(5 keywords)

Attachments

(1 file)

When an RTL textarea has a vertical scrollbar (because the content has more
lines than the size of the textarea), a horizontal scrollbar appears as well,
even when there is no actual need for it.
The horizontal scrollbar allows scrolling a small amount (probably the width of
the vertical scrollbar) leftwards.

This has the same regression range as bug 306349, and like it, was probably
caused by the fix to bug 240276.

Combined with bug 312550, this can make working with RTL textareas a very
annoying experience.
Attached file testcase
Notice the horizontal scrollbar on the top (RTL) textarea.
Keywords: testcase
This bug is probably not related to MacOS, because I'm seeing this regression also on Windows XP with Fx 1.5b2.  Fx 1.0.7 displays the textareas correctly.
=> All/All, based on comment #2.
OS: MacOS X → All
Hardware: Macintosh → All
Depends on: 312550
This was fixed by the patch for bug 312550.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
v.fixed on 1.8.0.1 with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1, no horizontal scrollbar with Uri's testcase in #1.
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.