drag and drop freezes firefox

RESOLVED DUPLICATE of bug 305970

Status

()

--
critical
RESOLVED DUPLICATE of bug 305970
13 years ago
9 years ago

People

(Reporter: khc, Unassigned)

Tracking

1.5.0.x Branch
PowerPC
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8b5) Gecko/20051015 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8b5) Gecko/20051015 Firefox/1.4.1

This seems to only happen on LinuxPPC, at least I cannot reproduce it on
LinuxX86. Dragging and dropping, for example reordering tabs, or dragging a link
to desktop to download the file, causes firefox to freeze and consume 100% CPU
most of the time.
Sometimes, but not always, the downloading occurs after I killed firefox.

Reproducible: Sometimes

Steps to Reproduce:
1. drag and drop a file to desktop to download
2.
3.

Actual Results:  
firefox freezes and consumes 100% cpu


Here's my buildconfig:
--enable-application=browser --enable-application=browser --disable-debug
'--enable-optimize=-Os -freorder-blocks -fno-reorder-functions -gstabs+
-fno-strict-aliasing' --disable-tests --enable-official-branding
--enable-default-toolkit=gtk2 --enable-xft --disable-freetype2 --enable-svg
--enable-canvas --enable-static --disable-shared
(Reporter)

Updated

13 years ago
Hardware: Other → Macintosh
Version: unspecified → 1.5 Branch

Comment 1

13 years ago
Changing component to tab browser as you're taking it as an example.
Component: General → Tabbed Browser

Comment 2

13 years ago
Confirming that it WFM in x86.  Do you know when it started crashing Firefox?

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 309453 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
(In reply to comment #3)
> 
> *** This bug has been marked as a duplicate of 309453 ***
 
The bug you are duping to is showing hangs on x86, this bug here is WFM on x86 according to comment 0 and comment 2. This bug is showing crashs on Linux PPC.

Reporter, can you supply a talkback record? See http://kb.mozillazine.org/Talkback
http://www.mozilla.org/quality/qfa.html

Do you use extensions? Does it also crash in safe mode?
Status: RESOLVED → UNCONFIRMED
Keywords: crash
Resolution: DUPLICATE → ---

Comment 5

13 years ago
Removing keyword crash. The reporter told firefox is hanging, but was asked in comment 2 when it started to crash. After coming back from the other bug I was assuming this one is a crasher when I filed comment 4.

Reporter, do you use official builds, or are you building yourself?
Keywords: crash
(Reporter)

Comment 6

13 years ago
(In reply to comment #2)
> Confirming that it WFM in x86.  Do you know when it started crashing Firefox?
> 

It doesn't crash firefox, but just freezes and consumes 100% CPU until I kill it.
(Reporter)

Comment 7

13 years ago
(In reply to comment #4)
> Reporter, can you supply a talkback record? See
> http://kb.mozillazine.org/Talkback
> http://www.mozilla.org/quality/qfa.html

Since it doesn't crash, only freezes, I don't know how talkback would help.

> Do you use extensions? Does it also crash in safe mode?
 
I've tried disabling all extensions except those that ships with firefox (DOM inspector and Reporter). From my memory I think this happens with a clean profile as well.

In response to your another comment, since I can't find a official linuxppc build, this is my own build, you can find my buildconfig in the initial report.
(Reporter)

Comment 8

13 years ago
I've done more testing:

1) Definitely happens with new profile, with a branch build as of last night
2) Doesn't happen if there's only 1 or 2 tabs
3) A comment on another bug has a workaround: https://bugzilla.mozilla.org/show_bug.cgi?id=309453#c13
4) Once the workaround is applied, future drag and drop does not have this buggy behavior
5a) Invoking the GtkFileChooser is also problematic: it will show the dialog but nothing in the file listing, the cursor is also in BUSY state and firefox freezes. The workaround does not apply when this happens.
5b) However, if I open up the file chooser after I applied the workaround (by doing a drag+drop, causes firefox to freeze, apply workaround to unfreeze), GtkFileChooser works fine.

Just want to emphasis again that this happens not only with drag+drop tabs, but also dragging links to other applications. But according to my investigations last night, it definitely relates to tab.

Comment 9

13 years ago

*** This bug has been marked as a duplicate of 305970 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
QA Contact: general → tabbed.browser
You need to log in before you can comment on or make changes to this bug.