Note: There are a few cases of duplicates in user autocompletion which are being worked on.

file help-index1.rdf - several bugs

RESOLVED FIXED

Status

Documentation
Help Viewer
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: lenochod, Assigned: Giacomo Magnini)

Tracking

({fixed1.8})

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.8b4) Gecko/20050913 SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.8b4) Gecko/20050913 SeaMonkey/1.0a

1) 2x <rdf:Description ID="SSL" - isn't view all

2)  nc:link="nav_help.xhtml#copying_saving__and_printing_pages" - 2x _ in
"saving__and"

3) 2x in section <rdf:Description about="#Navigator"> lines:
    <rdf:li>
        <rdf:Description ID="Navigator:controlling_popups"
          nc:name="controlling popups"
          nc:link="cs_priv_prefs_popup.xhtml#controlling_popups"/>
    </rdf:li>

4) change
        nc:link="nav_help.xhtml#Navigator:setting_image_as_wallpaper"/>
    to
        nc:link="nav_help.xhtml#setting_image_as_wallpaper"/>

5) subcategory
<rdf:Description about="#colors">
haven't category
<rdf:Description ID="colors"


6)  in
    <rdf:li>
       <rdf:Description ID="bookmarks:exporting_bookmarks"
         nc:name="exporting bookmarks"
     nc:link="customize_help.xhtml#exporting_or_importing_a_bookmark"/>
     </rdf:li>
 change
#exporting_or_importing_a_bookmark
on
#exporting_or_importing_a_bookmark_list

7) in
     <rdf:li>
       <rdf:Description ID="Composer:setting_page_colors"
         nc:name="setting page colors"
     nc:link="composer_help.xhtml#setting_page_colors_and_background"/>
     </rdf:li>
 change
#setting_page_colors_and_background
on
#setting_page_colors_and_backgrounds

Reproducible: Always

Comment 1

12 years ago
Good catch ;)

This should happen on the trunk as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 2

12 years ago
Looked at it:

> 1) 2x <rdf:Description ID="SSL" - isn't view all

This one actually do show up for me (trunk/branch). Not sure what's going on here.
 

> 5) subcategory
> <rdf:Description about="#colors">
> haven't category
> <rdf:Description ID="colors"

I can't find this, the only "<rdf:Description about="#colors">" I can find is
the one at line 237 (trunk/branch). And that looks OK. Are you refering to the
help-index1.rdf file in your cs-CZ.jar package?

The rest are straightforward.



(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Looked at it:
> > 5) subcategory
> > <rdf:Description about="#colors">
> > haven't category
> > <rdf:Description ID="colors"
> 
> I can't find this, the only "<rdf:Description about="#colors">" I can find is
> the one at line 237 (trunk/branch). And that looks OK. Are you refering to the
> help-index1.rdf file in your cs-CZ.jar package

SeaMonkey 1.0a Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050913 SeaMonkey/1.0a
In menu
  Help-Help Contents
In Left
  Index
There can't find "customizing web page" from
<rdf:Description about="#colors">
   <nc:subheadings>
     <rdf:Seq><rdf:li>
       <rdf:Description ID="colors:customizing_web_page"
         nc:name="customizing web page"
	 nc:link="customize_help.xhtml#changing_the_default_colors"/>
     </rdf:li></rdf:Seq>
   </nc:subheadings>
</rdf:Description>

I can't find in file help-index1.rdf line <rdf:Description ID="colors"
(Reporter)

Comment 4

12 years ago
(In reply to comment #2)
> Looked at it:
> 
> > 1) 2x <rdf:Description ID="SSL" - isn't view all
> 
> This one actually do show up for me (trunk/branch). Not sure what's going on here.

SeaMonkey 1.0a Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050913
SeaMonkey/1.0a
In menu
  Help-Help Contents
In Left
  Index
There I find item "SSL" but I can't find item "cipher technologies"
(Assignee)

Comment 5

12 years ago
(In reply to comment #3)
> There can't find "customizing web page" from ...
> I can't find in file help-index1.rdf line <rdf:Description ID="colors"

IMO, this one should be unified with "Customizing Fonts": both refer to the instructions on how to change the web page display (changing colors, fonts and themes), so probably a single entry pointing to customize_help.xhtml#changing_fonts_colors_and_themes should suffice. Suggestions?
I've fixed locally (added bonus: de-tabified the file) the others reported problems, and I'm investigating the SSL one further...
(Assignee)

Comment 6

12 years ago
(In reply to comment #4)
> There I find item "SSL" but I can't find item "cipher technologies"

Ok, got it, and actually found a few problems:
1) "cipher technologies" is under encryption, pointing to SSL-Edit ciphers, probably because of the reference to NSS encryption technologies (which is an outside link, actually out of date but covered in bug 311330)
2) There is no explanation of encryption/signing, which, IMO, should be added under encryption (->mail_sec_help.xhtml#about_digital_signatures_and_encryption)
3) Under the SSL category, IMO, we should add a link to the SSL protocols (->ssl_help.xhtml#ssl_protocol_versions).

For the above problem, my proposal is:
     <rdf:li>
       <rdf:Description ID="Customizing web page display"
         nc:name="Customizing web page display"
         nc:link="customize_help.xhtml#changing_fonts_colors_and_themes"/>
     </rdf:li>
removing the entries "Customizing Fonts" and "customizing web page".
(Assignee)

Comment 7

12 years ago
Another problem with SSL: there is a duplicated entry, one in the main #s section, and one in #SSL. Removed the first one as a start! :)

Comment 8

12 years ago
(In reply to comment #5)
> (In reply to comment #3)
> > There can't find "customizing web page" from ...
> > I can't find in file help-index1.rdf line <rdf:Description ID="colors"
> 
> IMO, this one should be unified with "Customizing Fonts": both refer to the
> instructions on how to change the web page display (changing colors, fonts and
> themes), so probably a single entry pointing to
> customize_help.xhtml#changing_fonts_colors_and_themes should suffice.
> Suggestions?

Sounds good to me. 


> I've fixed locally (added bonus: de-tabified the file) the others reported
> problems

Nice :) Personally, I would like this on the branch as  well. Will de-tabbing cause a lot of problems for localizers (since you actually change the whole file)?

Assignee: help.viewer → giacomo.magnini
(Assignee)

Comment 9

12 years ago
(In reply to comment #8)
> Sounds good to me. 

Do you mean my proposal in comment #6 is ok?

> Nice :) Personally, I would like this on the branch as  well. Will de-tabbing
> cause a lot of problems for localizers (since you actually change the whole
> file)?

A simple search and replace of one tab with 8 spaces (iirc) on the whole file will do, so not a big deal, and the file will have to be worked on anyway, since we are making some string changes. So I think it will be fine to put it on branch, since it restores some functionality as well.
Waiting for some input on my proposals about the SSL problem to provide a full patch.

Comment 10

12 years ago
(In reply to comment #9)
> (In reply to comment #8)
> > Sounds good to me. 
> 
> Do you mean my proposal in comment #6 is ok?
 
Yeah, but thinking of it, we should make sure something containing "colors" displays in the index.
(Assignee)

Comment 11

12 years ago
Created attachment 200754 [details] [diff] [review]
Full patch, with tab removal
(Assignee)

Comment 12

12 years ago
Created attachment 200755 [details] [diff] [review]
-w version for easier review, showing real changes only
(Assignee)

Updated

12 years ago
Attachment #200754 - Flags: review?(iann_bugzilla)

Comment 13

12 years ago
Comment on attachment 200755 [details] [diff] [review]
-w version for easier review, showing real changes only

>        <rdf:Description ID="Navigator:set_as_wallpaper"
>          nc:name="set as wallpaper"
>-	 nc:link="nav_help.xhtml#Navigator:setting_image_as_wallpaper"/>
>-     </rdf:li>
>-     <rdf:li>
>-       <rdf:Description ID="Navigator:controlling_popups"
>-         nc:name="controlling popups"
>-	 nc:link="cs_priv_prefs_popup.xhtml#controlling_popups"/>
>+         nc:link="nav_help.xhtml#setting_image_as_wallpaper"/>
>      </rdf:li>
Did you really mean to remove the controlling_popups bit?

Updated

12 years ago
Attachment #200754 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 14

12 years ago
(In reply to comment #13)
> Did you really mean to remove the controlling_popups bit?

Yes, it's a doubled entry. The first one is a few lines above (around 1325 in the patched file).
(Assignee)

Updated

12 years ago
Attachment #200754 - Flags: superreview?(neil.parkwaycc.co.uk)

Comment 15

12 years ago
Comment on attachment 200754 [details] [diff] [review]
Full patch, with tab removal

>-       <rdf:Description ID="Customizing Fonts"
>-         nc:name="Customizing Fonts"
>-	 nc:link="customize_help.xhtml#changing_fonts_colors_and_themes"/>
>+       <rdf:Description ID="Customizing"
>+         nc:name="Customizing colors and fonts"
>+         nc:link="customize_help.xhtml#changing_fonts_colors_and_themes"/>
Should be "Customizing Fonts and Colors" as per the section's title.
Attachment #200754 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
(Assignee)

Comment 16

12 years ago
Created attachment 201500 [details] [diff] [review]
What Neil Asked for. Carrying over r/sr+ (Checked in trunk and branch)
Attachment #200754 - Attachment is obsolete: true
Attachment #200755 - Attachment is obsolete: true
Attachment #201500 - Flags: superreview+
Attachment #201500 - Flags: review+

Comment 17

12 years ago
Comment on attachment 201500 [details] [diff] [review]
What Neil Asked for. Carrying over r/sr+ (Checked in trunk and branch)

Checking in
help-index1.rdf;
new revision: 1.46; previous revision: 1.45
done
Attachment #201500 - Attachment description: What Neil Asked for. Carrying over r/sr+ → What Neil Asked for. Carrying over r/sr+ (Checked in)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

12 years ago
Comment on attachment 201500 [details] [diff] [review]
What Neil Asked for. Carrying over r/sr+ (Checked in trunk and branch)

SM only inline help fix, no risk.
Attachment #201500 - Flags: approval1.8rc2?

Updated

12 years ago
Attachment #201500 - Flags: approval1.8rc2? → approval1.8rc2+

Comment 19

12 years ago
Comment on attachment 201500 [details] [diff] [review]
What Neil Asked for. Carrying over r/sr+ (Checked in trunk and branch)

Checking in (branch)
help-index1.rdf;
new revision: 1.44.8.1; previous revision: 1.44
done
Attachment #201500 - Attachment description: What Neil Asked for. Carrying over r/sr+ (Checked in) → What Neil Asked for. Carrying over r/sr+ (Checked in trunk and branch)

Updated

12 years ago
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.