Back Button and File menu when maximized no longer extends to left edge

RESOLVED FIXED

Status

()

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: kenta, Unassigned)

Tracking

({regression, uiwanted})

Trunk
x86
Windows XP
regression, uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051024 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051024 Firefox/1.6a1

When maximized under Windows XP, the toolbar "back" button should extend to the leftmost pixel of the screen, by Fitts Law.  Instead there is a 2px gap betwen the left edge of the screen and the "hot" area of the back button.

Similarly, the "File" menu should also be clickable on the left edge as well.

The button and the menu used to work this way, for example, in this nightly build:
http://www.mit.edu/afs/sipb.mit.edu/project/mozilla/fx/windows/nightly-installer/old/firefox-1.6a1.en-US.win32.installer.exe

but it has been broken to a non Fitts-law compliant behavior in the past month or so.

Reproducible: Always




Ironically, Internet Explorer has the current Firefox behaviour, with unclickable borders around the Back button and File menu.  This is one IExplore behavior that Firefox ought NOT try to emulate.

Here is a blog post I made back when Firefox was following Fitts' law correctly that explains things in more detail:

http://kenta.blogspot.com/005/09/firefox-fitts-law-correct.html

Bug 273427 complains that whereas Windows has the right behavior, Linux does not; now neither platform has the right behavior.
(Reporter)

Comment 1

13 years ago
I suspect the cause might be the following checkin

timeless%mozdev.org	2005-10-06 17:31

"Bug 243078 - Native Theme Rendering for Windows XP Menus, toolbars patch by silver@warwickcompsoc.co.uk r=dougt sr=neil"

which falls in the right timeframe and hits the right files.
(Reporter)

Comment 2

13 years ago
The correct link to the blog post is: 
http://kenta.blogspot.com/2005/09/firefox-fitts-law-correct.html
Blocks: 243078

Comment 3

13 years ago
This "regression" was somewhat deliberate (as you point out, IE has this behavior), so I'm tempted to mark this WONTFIX... but I'll wait and see what James has to say; he may agree with you that Fitt's law should be observed.
Component: Toolbars → XUL Widgets
Product: Firefox → Toolkit
Version: unspecified → Trunk

Comment 4

13 years ago
The problem is that I don't have any say in it. I just fix the bugs as described, unless told otherwise. :)

Bug 243078 wants native-correct rendering, and that's what it's getting. This means visually pleasing borders all the way around toolbars (at least in the Classic theme). The problem, of course, is that you can't hit the buttons so easily.

The Firefox devs decided to go for Fitts Law and have a crap appearance for the content area (scrollbars vs. sunken). They may want that again, I simply don't know and, until it is decided one way or another, all my work will be visually correct.

P.S. I did not want that stuff checked in to trunk, as it was designed only for the Firefox 1.5 branch, but people refused to have it backed out.

P.P.S. My personal opinion is that I'd rather have it look right. This is probably a bit biased though, as I never have Firefox maximised.

Updated

13 years ago
Flags: blocking1.9a1?
Keywords: regression

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
QA Contact: toolbars → xul.widgets
Is there a way to make the _look_ be the standard UI look, but have the active hit zone extend to the edge of the screen per Fitts' law, so that you can click on the button even if what you actually click is the sunken rebar edge? That would seem to be the optimal solution, IMHO.

(also posted this comment to dev-apps-firefox.)

Comment 6

13 years ago
I'm not sure of the button, but "File" should certainly be clickable on the outer left edge. MSIE doesn't use fully native menus. Applications like Paint do, and there you're able to click on the outer left edge. For the "back" button, I don't know, as there aren't really other native applications that allow to test it, but would it be so much of an effort to keep the current behaviour?

Comment 7

13 years ago
The fact MSIE doesn't use a fully native menu bar is totally irrelevant. XUL's components correspond to IE's Rebars, not to native menubars.

Beging able to click at the edge *and* having the correct appearance (borders on all sides) is not trivial, and I doubt it could really be made to work generically with <toolbox>/<toolbar> as would be needed.

Comment 8

13 years ago
(In reply to comment #7)
> The fact MSIE doesn't use a fully native menu bar is totally irrelevant. XUL's
> components correspond to IE's Rebars, not to native menubars.

By the way, IE 7 uses a fully native menu bar.
Hixie's suggestion in comment 5 is the right way to go. If that's not possible, then this is WONTFIX. OS native look and feel is more important than Fitts' Law in this application. It's important to ensure that the hotzone extends to window edges in fullscreen mode, but when maximized, we should act like any other w32 app. If you want better Fitts' Law support, buy a Mac.
Flags: blocking1.9a1?
Also, this shouldn't block continuing work on 243078. Not. At. All.
No longer blocks: 243078

Comment 11

13 years ago
(In reply to comment #9)
> Hixie's suggestion in comment 5 is the right way to go. If that's not possible,
> then this is WONTFIX. OS native look and feel is more important than Fitts' Law
> in this application.

Wow, you've just completely contradicted the solution chosen. Anyway, bug 313388 will "fix" this "bug", so marking depends.
Depends on: 313388

Updated

13 years ago
Blocks: 313388
No longer depends on: 313388

Comment 12

13 years ago
Fixed. Rah.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.