Last Comment Bug 313740 - Dragging bookmark from Safari to Camino removes bookmark rather than copies
: Dragging bookmark from Safari to Camino removes bookmark rather than copies
Status: RESOLVED FIXED
: fixed1.8.1.1, regression
Product: Camino Graveyard
Classification: Graveyard
Component: Bookmarks (show other bugs)
: unspecified
: PowerPC Mac OS X
P2 normal (vote)
: Camino1.5
Assigned To: froodian (Ian Leue)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-25 06:24 PDT by Smokey Ardisson (offline for a while; not following bugs - do not email)
Modified: 2006-12-05 10:37 PST (History)
8 users (show)
sfraser_bugs: camino1.0-
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Forces a call to NSDragOperationCopy if the dropped data is not Camino Bookmarks (1.37 KB, patch)
2005-10-25 20:38 PDT, Nick Kreeger
sfraser_bugs: review-
Details | Diff | Splinter Review
Possible alternative patch (1.31 KB, patch)
2005-10-25 21:35 PDT, Simon Fraser
nick.kreeger: review+
mikepinkerton: superreview+
Details | Diff | Splinter Review
Forces drag to NSDragOperationCopy if the dropped data is from an external app (4.17 KB, patch)
2006-12-03 09:48 PST, froodian (Ian Leue)
moz: review+
mikepinkerton: superreview+
Details | Diff | Splinter Review

Description User image Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-10-25 06:24:55 PDT
Spun off from bug 313338 (reporter never filed a follow-up, but it seemed significant enough):

"Also when transferring individual Bookmarks from Safari to the earlier Camino
version the transfer was a copy leaving the original with Safari. Now the
transfer is total eliminating the Bookmark from Safari."

If you drag a bookmark from Safari's manager to Camino's manager, the bookmark is removed from Safari's manager.  When we go the other way, we copy the bookmark into Safari and keep our original.

In 0.8.4, it was a copy both ways (although moving a bookmark from Safari to Camino resulted in the bookmark's URL being used as its name).  

Any chance this regressed due to changing bookmarks to the shared pasteboard format or whatever?
Comment 1 User image Simon Fraser 2005-10-25 08:33:23 PDT
Need to use the copy dragging mask for non-local drags.
Comment 2 User image Mike Pinkerton (not reading bugmail) 2005-10-25 14:16:33 PDT
but these aren't drags we originate. do those flags still matter on the drop site?
Comment 3 User image Wevah 2005-10-25 16:20:28 PDT
I think it can, if the source implements draggedImage:endedAt:operation: .
Comment 4 User image Simon Fraser 2005-10-25 18:15:47 PDT
Oh, hrm, misread. Yeah, I'm not sure if we can affect what Safari is doing.
Comment 5 User image Nick Kreeger 2005-10-25 20:38:52 PDT
Created attachment 200830 [details] [diff] [review]
Forces a call to NSDragOperationCopy if the dropped data is not Camino Bookmarks
Comment 6 User image Simon Fraser 2005-10-25 21:30:26 PDT
Comment on attachment 200830 [details] [diff] [review]
Forces a call to NSDragOperationCopy if the dropped data is not Camino Bookmarks

This doesn't fix the case of dragging into a root bookmark folder on the left.
Comment 7 User image Simon Fraser 2005-10-25 21:35:01 PDT
Created attachment 200837 [details] [diff] [review]
Possible alternative patch
Comment 8 User image Nick Kreeger 2005-10-25 21:43:56 PDT
Comment on attachment 200837 [details] [diff] [review]
Possible alternative patch

This is a better alternative to my patch, looks good, tested and works just fine
Comment 9 User image Mike Pinkerton (not reading bugmail) 2005-10-26 07:36:56 PDT
Comment on attachment 200837 [details] [diff] [review]
Possible alternative patch

sr=pink 

looks good.
Comment 10 User image Simon Fraser 2005-11-13 20:33:24 PST
I don't think I like this patch. It seems that we should be checking for more specific drag operations first, then falling back on NSDragOperationGeneric. It's really safari's problem that it's willing to do a "move" to another application.
Comment 11 User image Mike Pinkerton (not reading bugmail) 2005-12-11 10:44:51 PST
but how can we check other ones and fall back if the bug happens because we're doing just that? have we filed a bug with apple that safari is wrong? Doesn't help safari releases already in the field though. 

simon, what do you want to do here?
Comment 12 User image Simon Fraser 2006-01-15 21:07:33 PST
Pushing off the 1.0 list.
Comment 13 User image Smokey Ardisson (offline for a while; not following bugs - do not email) 2006-08-13 00:21:43 PDT
How should we proceed to fix this on our end?

It won't help with all the existing versions of Safari out there (esp. on 10.3.x), but could someone file a bug/talk to Safari team members and get them to fix the bug on their end for the future?
Comment 14 User image Chris Lawson (gone) 2006-10-29 10:54:29 PST
I don't suppose there's any way to know where the drag target is if it's not internal to Camino, is there?

If there is, couldn't we simply tell Safari "sorry, we're not moving bookmarks there"?
Comment 15 User image Chris Lawson (gone) 2006-11-22 15:18:27 PST
(In reply to comment #14)
> I don't suppose there's any way to know where the drag target is if it's not
> internal to Camino, is there?
> 
> If there is, couldn't we simply tell Safari "sorry, we're not moving bookmarks
> there"?

Ignore the above; I was thinking this bug was backwards of what it really is.

From IRC:

[6:01pm] <Wevah> we should be able to check for dragSourceView == nil or something cos if it's nil, it's from another app

If it's from another app, we should force a copy, rather than allowing the app to be stupid and move things to Camino.

Right?

cl
Comment 16 User image froodian (Ian Leue) 2006-12-03 09:48:10 PST
Created attachment 247335 [details] [diff] [review]
Forces drag to NSDragOperationCopy if the dropped data is from an external app
Comment 17 User image Wevah 2006-12-05 00:01:47 PST
Comment on attachment 247335 [details] [diff] [review]
Forces drag to NSDragOperationCopy if the dropped data is from an external app

codewise r=me
Comment 18 User image Mike Pinkerton (not reading bugmail) 2006-12-05 09:39:14 PST
Comment on attachment 247335 [details] [diff] [review]
Forces drag to NSDragOperationCopy if the dropped data is from an external app

sr=pink
Comment 19 User image froodian (Ian Leue) 2006-12-05 10:37:18 PST
Checked in on 1.8branch and trunk.

Note You need to log in before you can comment on or make changes to this bug.