Closed Bug 313840 Opened 16 years ago Closed 16 years ago

Scroll bars in AJAX apps don't disappear when they should

Categories

(Camino Graveyard :: HTML Form Controls, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 187435

People

(Reporter: bsulman, Assigned: mikepinkerton)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Camino Version 2005091204 (1.0a1)

In examples like this web site as well as gmail, scroll bars stick on the page when their form elements have disappeared.  This results in an orphaned scroll bar with no associated form element.

Reproducible: Always

Steps to Reproduce:
1.Go to the Layout Controls/b:window demo
2.Click the close box on one of the AJAX windows.

Actual Results:  
The text and window disappear, but the scroll bar stays, all by itself.

Expected Results:  
The entire 'window,' including the scroll bar, should disappear.

This problem also occurs in Gmail when a 'quick reply' that is long enough to require a scroll bar has been sent.
The User-Agent is wrong in the first line of the report because I was using CamiOptions to spoof as firefox.  I am actually using Camino.

*** This bug has been marked as a duplicate of 187435 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.