last-update.log not created if it does not already exist

RESOLVED FIXED in mozilla1.8rc1

Status

()

Toolkit
Application Update
--
major
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Darin Fisher, Assigned: Darin Fisher)

Tracking

({fixed1.8})

unspecified
mozilla1.8rc1
fixed1.8
Points:
---
Bug Flags:
blocking1.8rc2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
last-update.log not created if it does not already exist

the patch for bug 311531 was not quite right :-(
(Assignee)

Comment 1

12 years ago
Created attachment 200948 [details] [diff] [review]
v1 patch
Attachment #200948 - Flags: review?(benjamin)
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
Flags: blocking1.8rc1?

Comment 2

12 years ago
Darin, is the ramification here that we won't be able to get update logs from users using the RC? This doesn't effect the success of software update right?
(Assignee)

Comment 3

12 years ago
It means that in order to get log files from users in the field, we will need them to create an empty "updates/last-update.log" before they attempt to apply the update.

Comment 4

12 years ago
I suspect we won't slip and respin the RC to pick this up. But this would be a good ride along candidate if we end up doing an RC2 or something bigger comes up with RC1. adding our tracking text for that:

"not going to lose a day with this but could become a ride-along if we're forced
to respin by some other bug."

Updated

12 years ago
Attachment #200948 - Flags: review?(benjamin) → review+
(Assignee)

Comment 5

12 years ago
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
*** Bug 314078 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
There's no choice anyaway for a RC2, we have a couple of good patches that we would need, that are not risky, like this one. 

Comment 8

12 years ago
moving out to the 1.8 rc2 ride-along candidate list. We'll consider taking this if we do an RC2.
Flags: blocking1.8rc1? → blocking1.8rc2?

Updated

12 years ago
Attachment #200948 - Flags: approval1.8rc2+

Comment 9

12 years ago
I landed this for Darin.
Flags: blocking1.8rc2? → blocking1.8rc2+
Keywords: fixed1.8
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.